Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.6 16v fuel pump relay location?
#1
Hi , my berlingo just did not start in the morning , i was trying to find the fuel pump relay because i can not find it.
Reply
#2
Well it could be many things, can you describe what sounds its making when you try to start it? If you are really pointed in the fuel delivery direction then possibly fuel pump. They are common to fail and easy to replace.
Take exhaust and handbrake cables out
http://i.imgur.com/hYDXmsp.jpg
Drain the fuel the lazy way
http://i.imgur.com/o8HiivA.jpg
Now release the plastic light weight tank without worries, just hold it with your hands. Make sure all connectors are off and the filling neck is unscrewed from the top too. Voila
http://i.imgur.com/0vSwJCw.jpg
Jet wash the tank inside and outside. Use brush to scrub like mad inside to remove the dirt that has gathered over the years. Keeps clogging the fuel filter in the future.
http://i.imgur.com/MNYKRWQ.jpg
http://i.imgur.com/eb4kwDt.jpg
Throw away the old french mareli fuel pump and go make china great again (half price) http://www.ebay.co.uk/itm/391267855629?_...EBIDX%3AIT
http://i.imgur.com/pd9en04.jpg


tips: don't force any connections out with screw drivers etc, they are all press (like a button) and pull style.
Part number is 1525H8 http://i.imgur.com/XG4c6qA.png
Reply
#3
If it's a com2000 variety ie a later lingo from say 02-09 then the fuel pump relay is built into the psf1 (passenger side fuse box aka the big board with twenty odd fuses behind the passenger side headlight) under the bonnet and isn't swappable by itself, it's a replace the lot job as its soldered in and potted, however I will add that I have only ever had wiring faults and power supply faults cause none running issues, never touch wood had a none runner due to a psf1

If it's an early one it'll be part of the double relay second stage which only kicks in on cranking and is negatively triggered from the engine ecu

Chances are you you have a broken wire or power supply/earth fault somewhere...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
display fading (MFD B, not bulb related)
Last Post: sks01773
Today 07:50 PM
» Replies: 42
» Views: 6103
Are Mud Flaps the Answer ?
Last Post: iscom
Today 07:10 PM
» Replies: 4
» Views: 168
Head Light Bulbs
Last Post: dargoion
Today 05:52 PM
» Replies: 33
» Views: 988
radio code
Last Post: Tomcat3
Today 02:32 PM
» Replies: 3
» Views: 83
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Trevor
Today 02:13 PM
» Replies: 2
» Views: 43
Removing the rear roof storage bin (mk3 modutop)
Last Post: iscom
Today 01:31 PM
» Replies: 15
» Views: 6743
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 12:13 PM
» Replies: 4
» Views: 245
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 12:07 PM
» Replies: 1
» Views: 63
Rear light bulb holders - keeps dropping bulb.
Last Post: Top drive
Today 12:01 PM
» Replies: 7
» Views: 297
What website to pass time over a winters evening...
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 1
» Views: 258

[-]
Recent Visitors
Locations of visitors to this page