Thread Rating:
  • 24 Vote(s) - 3.42 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.6 Hdi engine trouble
#1
Sad 
Hi All.

I recently bought a 07 1.6 hdi and am having a bit of trouble with the engine. When i start it in the morning the van starts on the first turn but runs rough, dosent idle properly and the engine shakes a bit . when i drive the van for about a minute or two it runs fine and idles perfect.

Any idea what might be causing this anyone?

Reply
#2
(21-06-2011, 08:48 PM)00jes Wrote:  Hi All.

I recently bought a 07 1.6 hdi and am having a bit of trouble with the engine. When i start it in the morning the van starts on the first turn but runs rough, dosent idle properly and the engine shakes a bit . when i drive the van for about a minute or two it runs fine and idles perfect.

Any idea what might be causing this anyone?
sounds like heater plugs not working but hdi dussnot nead them much till it is very cold but thay do come on to aide cold starts and run for a bit when first star till it warms up a bit

Reply
#3
Welcome

When was it last serviced?

Mileage?

Is the EML on or any codes stored in the ECU to give you a clue?
Reply
#4
air in the fuel system.... try the priming pump next to fuel filter housing... pump until firm, start engine and pump a few more times. Have a look at fuel lines for any air bubbles. If you have clear lines??
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
[-] The following 2 users say Thank You to adam3rdcanvey for this post:
  • j90xxx, tucker
Reply
#5
Thanks, Adam.
Think I have the same problem, but not as bad.
Revs fluctuate (good word!) a little on initial start-up and engine is tiny bit rough sounding. Nothing major.
Once I start off it is fine; goes well, no hesitation and pulls like a train.
Will try your suggestion.:thumbsup:
Reply
#6
is worth a pump.... easiest thing first eh??
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#7
Try replacing the fuel filter, air can be induced into the fuel filter's rubber seals on the side of the filter, where the in/out let pipes attach. this is the common cause for such a rough running 1.6HDI. INSPECT THE FUEL PIPES AS WELL, ENSURING GOOD TIGHT CONNECTIONS AND ARE OF GOOD CONDITION E.G.NOT BROKEN. LOOK FOR SIGNS OF MOISTURE AROUND THE CONNECTINS / FILTER CONNECTIONS. GOOD LUCK ..
Reply
#8
(21-06-2011, 08:48 PM)00jes Wrote:  Hi All.

I recently bought a 07 1.6 hdi and am having a bit of trouble with the engine. When i start it in the morning the van starts on the first turn but runs rough, dosent idle properly and the engine shakes a bit . when i drive the van for about a minute or two it runs fine and idles perfect.

Any idea what might be causing this anyone?


Probably you have problems with glow plugs or(and) it's supply chains
Reply
#9
Did you sort this??
Reply
#10
(07-08-2013, 08:52 PM)Pingzone Wrote:  Did you sort this??

Unfortunately Pingzone the thread is now over two years old and I haven't seen the OP for a while...
The Older I get the Better I Was!  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Today 01:30 PM
» Replies: 3
» Views: 176
Help needed have immobiliser fault and fan probl...
Last Post: Dennyboy
Today 01:02 PM
» Replies: 0
» Views: 21
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Andre
Today 11:23 AM
» Replies: 2
» Views: 203
Lucas mechanic fuel pump - disassembly and timin...
Last Post: yanivh
Today 11:01 AM
» Replies: 0
» Views: 29
Head Light Bulbs
Last Post: Tree
Today 08:38 AM
» Replies: 32
» Views: 903
EGR solenoid
Last Post: silver-slug
Today 08:31 AM
» Replies: 19
» Views: 1427
ABS Modul
Last Post: brajomobil
Today 08:07 AM
» Replies: 2
» Views: 114
Speedo/milometer fault
Last Post: Gixxerguyk8
Today 12:28 AM
» Replies: 15
» Views: 1460
Which wheel nuts?
Last Post: Stu999
Yesterday 11:50 PM
» Replies: 0
» Views: 57
VAN SECURITY
Last Post: ricc
Yesterday 08:29 PM
» Replies: 5
» Views: 178

[-]
Recent Visitors
Locations of visitors to this page