Thread Rating:
  • 13 Vote(s) - 2.92 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.9D Revving Uncontrollably - Blue Smoke
#1
Hi.

Iv recently bought a 2006 non turbo 1.9d berlingo. The van drives spot on for most of the time but every 50 or miles or so the engine will rev its tits off and blue smoke pours out the back. Then when I turn the key off quickly to cut it out it still revs on its own for another 5 seconds(ish). I have also noticed the yellow engine management light pops up for a few seconds every now and again.

This is obviously very dangerous and I need it fixed asap! My mechanic cant figure out why its doing this, all we know is it must be feeding on its own oil.

If anyone can help they will be a hero!

Thanks,

Dan.
Reply
#2
Feeding on its own oil ..... try removing the engine breather from the air intake to prove, a good mod anyway.

If it switches off and stops on the key then it cannot be fully running on the sump oil so perhaps you have a pump or injector problem ? .... Run a good dose of injector cleaner first ....

Simple checks / fixes first, always cheaper and often effective.

Just my first thoughts.... Let us know how you get on.
[-] The following 1 user says Thank You to geoff for this post:
  • addo
Reply
#3
(09-08-2013, 11:32 AM)geoff Wrote:  Feeding on its own oil ..... try removing the engine breather from the air intake to prove, a good mod anyway.

If it switches off and stops on the key then it cannot be fully running on the sump oil so perhaps you have a pump or injector problem ? .... Run a good dose of injector cleaner first ....

Simple checks / fixes first, always cheaper and often effective.

Just my first thoughts.... Let us know how you get on.

Is that the black C shaped pipe on the right top of the engine. So if I take that off, start her up and see what happens?

ill get some injector cleaner on the way home later. When you say the pump, I have had someone tell me it could be a buggered pump. Do my vans symptons relate to a knackered oil pump?

Thanks for the speedy response

Dan
Reply
#4
Yes a C shaped pipe ...... pump ? ... wait and see what the cleaner does and also for more informed advice from others. Don't go too deep too quick.
Reply
#5
Ive removed this post, as Geoff pointed out its incorrect, I was thinking of a previous Ford I owned when i replied.
Reply
#6
The engine breather feed directly to the air intake ductings and is completely independant of the EGR system !

EGR's do give trouble from time to time and IF yours is misbehaving it can be satisfactorily blanked off ( on the 1.9D ) without issue and is simply a matter of blocking off the two vacuum pipes feeding it, but don't go there yet.

Hit the simple stuff first and work out from there. Remember just do one thing at a time and evaluate the results before moving onto anything else, most important otherwise you won't know what has caused / cured what !
Reply
#7
Yep its definitely blue smoke, so oil.

Tonight ive taken off the inlet & EGR valve. Iv given it all a good clean out and checked the breathers, there fine.

The EGR was quite caked up the sides, about 10mm of gunky oil thick. Now cleaned.
Reply
#8
Is that much gunk normal?
Reply
#9
I'd have thought 10mm was more undesirable than normal as what you have is a function of the emissions control.

My 1.9D at 68k had around 3mm plastered around the EGR and the intake from there to the engine was full of oily slime.

I blanked off the engine breather connection at the air intake and have temporarily taken the engine breather and vented it to a catch pot in the engine bay so I can see what quantity of fumes etc are coming out of the engine, currently virtually nil ( or should I say normal ) but then it is low mileage.

My EGR is blanked and this will be the biggest help for the future and the vehicle is smoother and generally happier for it, even my wife noticed it so a true vote of confidence !
Reply
#10
So a blanking kit from ebay should do the job long term?

Iv drove 75 miles in the van today and it was spot on. No blue smoke or revving. Fingers crossed its fixed it.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Help needed have immobiliser fault and fan probl...
Last Post: Dennyboy
Today 01:02 PM
» Replies: 0
» Views: 4
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Andre
Today 11:23 AM
» Replies: 2
» Views: 195
Lucas mechanic fuel pump - disassembly and timin...
Last Post: yanivh
Today 11:01 AM
» Replies: 0
» Views: 23
Head Light Bulbs
Last Post: Tree
Today 08:38 AM
» Replies: 32
» Views: 892
EGR solenoid
Last Post: silver-slug
Today 08:31 AM
» Replies: 19
» Views: 1424
ABS Modul
Last Post: brajomobil
Today 08:07 AM
» Replies: 2
» Views: 103
Speedo/milometer fault
Last Post: Gixxerguyk8
Today 12:28 AM
» Replies: 15
» Views: 1454
Which wheel nuts?
Last Post: Stu999
Yesterday 11:50 PM
» Replies: 0
» Views: 51
VAN SECURITY
Last Post: ricc
Yesterday 08:29 PM
» Replies: 5
» Views: 174
Clanking Brake Pedal Solved At Last!
Last Post: rickandbev16
Yesterday 06:53 PM
» Replies: 17
» Views: 3444

[-]
Recent Visitors
Locations of visitors to this page