Thread Rating:
  • 4 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2009 1.6HDi 75, won't turn over or start
#1
Have owned our 2009 Bermingo 1.6HDi 75 for about 7 or 8 months now, and this is the first serious problem.
I'd been diving the car all morning. About 20 miles.
Dropped home for something and was in the house for about 10 minutes. Came out and the car won't start. Turn the key and nothing happens. Battery is fine, but starter doesn't even turn over.

Anyone got any ideas?

Something similar happened to me once, about 3 weeks ago with it. Turned the key and nothing happened, but I just tried again and on the third go it started up, business as usual.

I'm guessing some electrical issue, maybe a loose connection, but, could it be something more serious?

Any help gratefully received.
Thanks.
Reply
#2
If you're getting all the correct dash lights when you switch on,
it could be something as simple as a starter relay but it's dangerous and sometimes
expensive to make assumptions as this fault could be due to a number of things.
Start with the simple stuff. Re-check your battery connections etc.
The Older I get the Better I Was!  Cool
Reply
#3
Get battery checked out , a "dead" battery can show 12Volts and dash lights but not enough amps to start.

As ol Jeffers says you can waste lots of money on guessing , simple things first

Jon
Reply
#4
1st step is to check battery, as said
Berlingo starters on the MK3 go through a fuse in the underbonnet box, when the starter fails, or gets tired, they often blow the fuse. My guess is it ultimately needs a starter (they fail quite often), but a fuse may get it going once or twice more.
Reply
#5
I'd thought that 20A fuse blowing regularly was a sign of the fuse outfeed contact becoming higher resistance than designed, with a net increase in current draw.
Reply
#6
Good point addo.

Its always worth looking at cables and terminals for corrosion and being loose , a good source of resistance.

Worth a clean up and tighten before going further.

Jon
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 33
Next gen berlingo multispace
Last Post: churmy
Yesterday 10:30 PM
» Replies: 0
» Views: 31
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1499
Is anyone buying a new car AFTER April 2017?
Last Post: Jed Clampit
Yesterday 09:25 PM
» Replies: 10
» Views: 184
Another seat belt question
Last Post: berreke
Yesterday 09:02 PM
» Replies: 1
» Views: 36
hi all
Last Post: Jed Clampit
Yesterday 08:39 PM
» Replies: 2
» Views: 47
Tyre Change...old on front new on back
Last Post: RocketVANman
Yesterday 08:26 PM
» Replies: 12
» Views: 196
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Yesterday 08:10 PM
» Replies: 8
» Views: 333
Newbie
Last Post: j.ted
Yesterday 08:03 PM
» Replies: 6
» Views: 104
Fuel rail pipe replacement
Last Post: Peter Palmer
Yesterday 04:50 PM
» Replies: 3
» Views: 91

[-]
Recent Visitors
Locations of visitors to this page