Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
7 inch touchscreen
#1
hello ...quick post regards my 2015 berlingo fitted with the new 7" touch screen media interface ...now .....4 weeks and 2500 miles in .....the van has been for its 1st service at 1000 miles and now at 2500 miles i have had to contact the dealer as the touch screen has started to reset itself occasionally whilst driving ....my dealer has stated a software update is required that takes around 1.5 hours to install....wondering if anyone else here has experienced any issues with their systems
Reply
#2
Have same issue, did this randomly for first 3 days then didn't do it for 3 weeks, just started doing it again a couple of days ago. Haven't contacted the dealer yet.
Reply
#3
(05-08-2015, 10:54 PM)QuickBlackDog Wrote:  Have same issue, did this randomly for first 3 days then didn't do it for 3 weeks, just started doing it again a couple of days ago. Haven't contacted the dealer yet.

thank you for your feedback and good luck Quickblackdog..so it seems there possibly is an issue ...hopefully just the software as i mentioned ...i will post after the 15th August when i am due back to the dealer!!
Reply
#4
hello an update as promised on the touchscreen ....visited the dealer yesterday having been previously informed an update was required ....only to be told the unit was up to date and no fault could be found ...not too pleased to say the least ...the only positive is that for the last week or so there have been no issues with the unit resetting itself / albeit i have had fairly short days in the van of sub 100 miles daily...now with some 4000 miles covered and is good apart from what i can only hope was a glitch of some kind with the screen .....
Reply
#5
(16-08-2015, 12:47 AM)carloski Wrote:  hello an update as promised on the touchscreen ....visited the dealer yesterday having been previously informed an update was required ....only to be told the unit was up to date and no fault could be found ...not too pleased to say the least ...the only positive is that for the last week or so there have been no issues with the unit resetting itself / albeit i have had fairly short days in the van of sub 100 miles daily...now with some 4000 miles covered and is good apart from what i can only hope was a glitch of some kind with the screen .....

Hi there! I've only just taken delivery of my new 1.6 Enterprise van! Same problem with the touchscreen resetting! I've had my 65 plate van for less than 24 hours and its developed the same problem as you! Strangely enough, I was driving a 15 plate Berlingo courtesy van before my new one arrived and that too had the same problem with the 7" touchscreen resetting continually! I'm just about to contact the dealer now, but wondered if you could shed more light on any software update that you might heard of from another dealer! Many thanks!
Reply
#6
hi guys, sorry to but in....not relevant i know....but regarding the touchscreen, are there any instructions on how to use etc, i have just bought a 65 plate berlingo enterprise and i'm wanting to add a reversing camera to it......cant find any info on the make etc...just looking to see if it has connections on the back to accommodate and how to remove the unit.......cheerz ........any help gratefully received.......
Reply
#7
(02-09-2015, 07:21 AM)Dino Wrote:  
(16-08-2015, 12:47 AM)carloski Wrote:  hello an update as promised on the touchscreen ....visited the dealer yesterday having been previously informed an update was required ....only to be told the unit was up to date and no fault could be found ...not too pleased to say the least ...the only positive is that for the last week or so there have been no issues with the unit resetting itself / albeit i have had fairly short days in the van of sub 100 miles daily...now with some 4000 miles covered and is good apart from what i can only hope was a glitch of some kind with the screen .....

Hi there! I've only just taken delivery of my new 1.6 Enterprise van! Same problem with the touchscreen resetting! I've had my 65 plate van for less than 24 hours and its developed the same problem as you! Strangely enough, I was driving a 15 plate Berlingo courtesy van before my new one arrived and that too had the same problem with the 7" touchscreen resetting continually! I'm just about to contact the dealer now, but wondered if you could shed more light on any software update that you might heard of from another dealer! Many thanks!
Reply
#8
Hi all,my 7in touchscreen radio wont operate unless the ignition is on.I have not had any probs with the screen resetting.(XTR100 s&s ETG6).I have tried pressing all the buttons and read the manual(as much use as a chocolate fireguard).I don't want to go to the dealer as its a 20 mile round trip.So if anyone has got a solution i would appreciate it..
Reply
#9
My new 65 plate Enterprise is doing the same. I only got it Friday but today (Monday) the screen reset itself 4 times in a 4 miles journey to work. It has done it a total of 10 times today.

What is annoying (apart from missing stuff on the radio and making a complete mockery of the news) is that if I have the volume down, it starts up again with the volume up!

If I am playing music from a USB stick, I will hear it stutter a couple of times just prior to the screen going off and it restarting.

I have not noticed any pattern to it yet.
Reply
#10
I'd say it needs to go back for a new stereo, as it's not fit for purpose.

If everyone hassled Citroen they might do something about it.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Next gen berlingo multispace
Last Post: churmy
Today 04:58 PM
» Replies: 7
» Views: 102
New Berlingo Auto Box - Anyone have one?
Last Post: Capelbond
Today 04:10 PM
» Replies: 9
» Views: 351
Newbie
Last Post: Onall4
Today 03:16 PM
» Replies: 0
» Views: 17
Finally a B9 Haynes Manual
Last Post: Satellitemark
Today 02:32 PM
» Replies: 37
» Views: 2394
glow plugs
Last Post: z1000pete
Today 10:21 AM
» Replies: 0
» Views: 27
Is anyone buying a new car AFTER April 2017?
Last Post: doofer
Today 09:10 AM
» Replies: 12
» Views: 227
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Hora
Today 07:04 AM
» Replies: 5
» Views: 157
Fuel rail pipe replacement
Last Post: polar
Today 06:54 AM
» Replies: 4
» Views: 102
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 48
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1572

[-]
Recent Visitors
Locations of visitors to this page