Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Alternator???
#1
Star 
Hi Guys, wondering if you could help me,

I have a Mk1 1.9d berlingo. I turned the engine on the other day and the battery light stayed on with the engine running, everything worked fine at this time driving at night with full beam lights on and radio.

I started the van maybe 5 times, that evening after checking the wires to the alternator (Theres only two?) but the light remained on when the engine is running.

Since then I have used the van multiple times and hasn't failed to start yet, but there is no power to the radio and full beam lights wont stay on? I started the van over 6 times today with a friend trying to determine the source of the problem.

Does anyone have any ideas as to what could be wrong and how to fix?
Reply
#2
Hi cookie
First of all to rule out the alternator get a meter on it and check the output, should be about 14.5 v.
there is an engine running relay that can play up if the earth connection is faulty. Its mounted on the inner n/s wing
Reply
#3
Hi Brodfather

Thanks for the quick reply.

I have never been great with electrics, am I testing the two connections points on top of the alternator for 14.5v?
Reply
#4
Hi
With the engine running and lights on test the voltage at the battery, if your alternator is OK it should be 14.5 volts. With the engine stopped it will be about 12.5 or so .
The large wire from the alternator supplies the battery , it is the output from the alternator , the smaller wire is the feed that makes the alternator work. it should have 12 volts at it with ignition on.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Tyre Change...old on front new on back
Last Post: Top drive
Today 07:13 AM
» Replies: 6
» Views: 80
Newbie
Last Post: Jed Clampit
Today 12:23 AM
» Replies: 3
» Views: 57
Finally a B9 Haynes Manual
Last Post: Satellitemark
Yesterday 08:26 PM
» Replies: 33
» Views: 2230
Fuel rail pipe replacement
Last Post: Peter Palmer
Yesterday 08:19 PM
» Replies: 2
» Views: 49
REAR AXCEL
Last Post: Tomcat3
Yesterday 07:31 PM
» Replies: 5
» Views: 139
Berlingo B9 2008 Just Testing The Water
Last Post: nickyboy4
Yesterday 06:34 PM
» Replies: 0
» Views: 39
Starting issues
Last Post: technique1966
Yesterday 06:00 PM
» Replies: 0
» Views: 35
Insurance cost
Last Post: jonny705
Yesterday 05:33 PM
» Replies: 0
» Views: 41
Are Mud Flaps the Answer ?
Last Post: Top drive
Yesterday 04:02 PM
» Replies: 11
» Views: 322
Is anyone buying a new car AFTER April 2017?
Last Post: Solent
Yesterday 03:35 PM
» Replies: 1
» Views: 60

[-]
Recent Visitors
Locations of visitors to this page