Thread Rating:
  • 4 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bad A/C wiring/electrical fault?
#1
Hi bros,

Have a small question to ask regarding berlingo mk1 A/C compressor. By default/based on experience, how long does it take for the A/C compressor (and radiator fan) to start after turning the A/C on?

Experiencing late kick in every now and then. A/C took more than 10 min to start after pushing the A/C button on. However once kicked in it works fine blows cold air. On normal days it turns on almost immediately (3-5 seconds, 30 secs top)

Suspect is bad relay in the fuse box or fan switch? Seeking advice from the gurus and bros here. Thanks
Reply
#2
Update from mechanic: Seems like wiring/electrical issue. One of the pressure switch pin has no power. Big problem is he can't remember which wire it leads to. Any experts' advice? Thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Next gen berlingo multispace
Last Post: ron
Today 11:09 PM
» Replies: 18
» Views: 341
Taking along time to heat up/warm the cabin
Last Post: berreke
Today 10:07 PM
» Replies: 17
» Views: 267
clunking noise
Last Post: Johny555
Today 09:58 PM
» Replies: 7
» Views: 139
Supermarket Diesel
Last Post: Opensauce
Today 08:55 PM
» Replies: 8
» Views: 196
Clutch Bleeding
Last Post: Opensauce
Today 08:38 PM
» Replies: 2
» Views: 29
What to look for when buying?
Last Post: my mucker
Today 04:59 PM
» Replies: 7
» Views: 121
Are Mud Flaps the Answer ?
Last Post: doofer
Today 10:01 AM
» Replies: 15
» Views: 503
Head Light Bulbs
Last Post: doofer
Today 09:51 AM
» Replies: 37
» Views: 1225
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 08:54 AM
» Replies: 3
» Views: 143
New tablet fitted
Last Post: Andre
Today 08:31 AM
» Replies: 1
» Views: 83

[-]
Recent Visitors
Locations of visitors to this page