Thread Rating:
  • 18 Vote(s) - 3.56 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Battery light
#1
On occasions recently when switching off the engine the battery (ignition) light stays on with the keys removed.
The remote key fob will not lock/unlock the doors, but the key will.
The battery light stays on (along with odometer and multi-function display) for about 15 mins.
This has happened 3 times now in 2 weeks.
Suggestions...
Reply
#2
Have bought and fitted a new remote battery. (CR 2016)
Still no change.
Battery light and display lights etc. still on with keys out and doors locked...
Even checked battery voltage and alternator charging; all fine.
Looks strange in the dark when parked with all the dash lights on.
Confusedcratch:
Reply
#3
I don't wish to be the harbinger of doom but this sounds like a possible BSI problem. Take a look here and you'll see that it's possible. http://www.bba-reman.com/content.aspx?co...ol_failure
The Older I get the Better I Was!  Cool
Reply
#4
Hope not...
Thanks, anyway.
Reply
#5
Read the reset procedure.
Don't like the disclaimer bit at the bottom.
Scary....
Reply
#6
(30-07-2011, 09:52 AM)j90xxx Wrote:  Read the reset procedure.
Don't like the disclaimer bit at the bottom.
Scary....

Put the driver's window down, lift the bonnet and ensure all equipment is switched off.

Ensure all doors are closed and remove key from the ignition.

Wait for 3 minutes, disconnect the vehicle battery and wait 15 seconds.

Reconnect the vehicle battery, wait a further 10 seconds (do not open doors.).

Switch on the side lights through the driver's window.

Switch on the ignition and check system's functionality.

Hold lock button on key down for 10 seconds.

Remove key open & close door test central locking system.

Start the engine and complete the system's check.

Failure to follow this procedure could result in incorrect operation of many BSI related items.


Yep!! Scary stuff!
But if your problems get any worse then worth a punt! I don't think the recon. units are too expensive though. That company is a couple of miles from me and very well established.


The Older I get the Better I Was!  Cool
[-] The following 1 user says Thank You to Ol'Jeffers for this post:
  • j90xxx
Reply
#7
Thanks Jeffers.
Reply
#8
It decided to cure itself, with no input from me.
Lasted 2 weeks with no problems, then did it again for a week!
Then cured itself again...
Been fine for a few days.
Don't you love intermittant faults!:brickwall:
Reply
#9
Reminds me of the old saying "If it ain't fixed, don't break it" or something along those lines :whistle::whistle::whistle:
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#10
It has been fine now for about 2 months, no further problems.
Yet...Confusedcratch:
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Tyre Change...old on front new on back
Last Post: malgpz900
Today 09:20 PM
» Replies: 2
» Views: 37
Finally a B9 Haynes Manual
Last Post: Satellitemark
Today 08:26 PM
» Replies: 33
» Views: 2202
Fuel rail pipe replacement
Last Post: Peter Palmer
Today 08:19 PM
» Replies: 2
» Views: 33
REAR AXCEL
Last Post: Tomcat3
Today 07:31 PM
» Replies: 5
» Views: 129
Berlingo B9 2008 Just Testing The Water
Last Post: nickyboy4
Today 06:34 PM
» Replies: 0
» Views: 26
Starting issues
Last Post: technique1966
Today 06:00 PM
» Replies: 0
» Views: 26
Insurance cost
Last Post: jonny705
Today 05:33 PM
» Replies: 0
» Views: 30
Newbie
Last Post: j.ted
Today 04:40 PM
» Replies: 2
» Views: 41
Are Mud Flaps the Answer ?
Last Post: Top drive
Today 04:02 PM
» Replies: 11
» Views: 309
Is anyone buying a new car AFTER April 2017?
Last Post: Solent
Today 03:35 PM
» Replies: 1
» Views: 51

[-]
Recent Visitors
Locations of visitors to this page