Thread Rating:
  • 8 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Battery light staying on with key out.
#1
Sad 
Hi there!

Ok, so I've been researching this problem and have tried a couple of things with no luck.
Can you help as I'm meeting a lovely women at the weekend and don't want to be disconnecting my battery!!

History:
Over the last few months the central locking has been tempermental with the door sensor on the drivers door closing and opening. If you shut it carefully it'll be ok and you could lock the car.

A couple of days ago I sprayed some 'non-belt slip' spray over the alternator belt (it was squeeling badly), I sprayed quite a bit too.
Since then the battery indicator light stays on when you take the key out and the car instruments are still alive & cannot use central locking.

I've looked around and tried to reset the BSI? nothing seems to happen and the battery light still stays on.
I have been disconnecting the battery at night, I've recently replaced the battery too and this one is brand new and 2 weeks old.

I'm thinking maybe I've created a short with the spray? or maybe damaged the alternator or voltage regulator?
The battery reads over 13v when the engine is running and stays just over 12v when off.

Any thought's on this?

Like another post I'm hoping it will fix itself but no luck so-far.
Maybe I'll keep the battery connected overnight and see what happens!!!

Thanks for any ideas you can come up with.
Graham.
Reply
#2
Think you may have a U/S alternator there mate ???
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#3
Yep get alternator tested/ overhauled at garage, or you'll be going through a lot of batteries Smile
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#4
ouch! funny enough I've just been to the supermarket and the first time in 2 days the battery light has not come on after swtiching off then removing key!
Just like the other guy in the forum maybe where he had it for a couple of weeks and it's been fine for over 2 months.
I'll keep my eye on it anyway and if it continues certainly get the alternator check out.
Thanks!!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Odd Issues with Rear Door Sensor
Last Post: GerardKeating
Today 12:27 AM
» Replies: 0
» Views: 3
Gearbox Fluid
Last Post: AlanS
Today 12:18 AM
» Replies: 14
» Views: 331
REAR AXCEL
Last Post: ajcommercial
Yesterday 11:57 PM
» Replies: 0
» Views: 6
Fuel Guage wrong
Last Post: ajcommercial
Yesterday 11:46 PM
» Replies: 2
» Views: 94
Longitudinal Roof rails on 2010 model
Last Post: Chrisville
Yesterday 08:42 PM
» Replies: 0
» Views: 26
radio code
Last Post: Tomcat3
Yesterday 07:14 PM
» Replies: 1
» Views: 40
Donation
Last Post: terryd999
Yesterday 06:15 PM
» Replies: 2
» Views: 39
Beeping with no error lights!!!
Last Post: sjparky
Yesterday 05:34 PM
» Replies: 11
» Views: 3760
Good Evening to you all.
Last Post: ron
Yesterday 04:33 PM
» Replies: 7
» Views: 208
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Yesterday 01:30 PM
» Replies: 3
» Views: 209

[-]
Recent Visitors
Locations of visitors to this page