Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Blower problems
#1
Hey people new to the forum and berlingo ownership .
From i bought the van been having a problem with the blower .
It only works on setting 4 , now i followed the instructions and changed it out but prob still there
Ive hooked my multi meter up to the plug going into the blower and setting 1-3 im only getting 1.10volts and on setting 4 im getting 14volts , does this mean my switch is nackered .

Cheers people
Reply
#2
this might help, a friend recently had the same problem on a corsa and it turned out to be the heater resistor. I would check your resistor as this could be wrong one, just showing you a pic, the resistor screws into heater box and wiring plugs in, http://www.ebay.co.uk/itm/HEATER-BLOWER-...35e5255f16
[Image: 2dedca76-4da1-4bd2-aea1-452ddda68256.jpg]
Reply
#3
Cheers can anyone tell me how i can access this up in the back of the dash and how do u remove the glove box ?? To get in there
Reply
#4
If its a mk2 you have to get on your knees and look under the glove box, there is 3 possibly 4 round plastic clips to remove. fold down the carpet panel then look up under the dash and you will see the blower motor. The resistor pack is visible and just unclips to remove. Its sounds very much like the resistor pack has gone make sure you check which part you have before buying as there are a few different versions available.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#5
Funny things heaters, take a look at this short posting by myself on 11/07/13

http://www.berlingoforum.co.uk/thread-72...ght=heater

I was all set to do some dismantling and spend money but all came good and still ok over 18 months later .......
Reply
#6
Cheers people found it up under the dash and got a new one from citroen for a cool £30 and all sorted .

Thanks again for all the help
[-] The following 1 user says Thank You to John Mc Kinney for this post:
  • ians_lingo
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
display fading (MFD B, not bulb related)
Last Post: sks01773
Today 07:50 PM
» Replies: 42
» Views: 6103
Are Mud Flaps the Answer ?
Last Post: iscom
Today 07:10 PM
» Replies: 4
» Views: 168
Head Light Bulbs
Last Post: dargoion
Today 05:52 PM
» Replies: 33
» Views: 988
radio code
Last Post: Tomcat3
Today 02:32 PM
» Replies: 3
» Views: 83
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Trevor
Today 02:13 PM
» Replies: 2
» Views: 43
Removing the rear roof storage bin (mk3 modutop)
Last Post: iscom
Today 01:31 PM
» Replies: 15
» Views: 6743
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 12:13 PM
» Replies: 4
» Views: 245
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 12:07 PM
» Replies: 1
» Views: 63
Rear light bulb holders - keeps dropping bulb.
Last Post: Top drive
Today 12:01 PM
» Replies: 7
» Views: 297
What website to pass time over a winters evening...
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 1
» Views: 258

[-]
Recent Visitors
Locations of visitors to this page