Thread Rating:
  • 2 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Burning" smell
#1
When i start the car up and put the heater on i get a strong smell like something electrical is overheating. it tends to fade away after a while though.Does anybody else get it?
Reply
#2
It might be the curry smell from a coolant leak on the heater matrix.
So where does this bit go then ?
Reply
#3
(17-02-2014, 10:52 AM)ffrenchie Wrote:  It might be the curry smell from a coolant leak on the heater matrix.
It`s done 18k. only 3 yrs too....
Reply
#4
did you find what was causing this problem
Reply
#5
(14-12-2014, 03:20 PM)mayo13 Wrote:  did you find what was causing this problem

I get it on mine occassionally its done 186000 miles i suppose its the resistors going west but il wait till i need to do it...just hope its warm weather!
Reply
#6
make sure its not the injectors leaking combustion gas into the heater blower.
Reply
#7
(31-01-2016, 05:57 PM)robertkhan@mail.com Wrote:  
(14-12-2014, 03:20 PM)mayo13 Wrote:  did you find what was causing this problem

I get it on mine occassionally its done 186000 miles i suppose its the resistors going west but il wait till i need to do it...just hope its warm weather!

I know the smell i had garages in the scottish borders for years and and its burning electrical resistors under dash but no point taking that out unless absolutely need to! If its the heater and it packs in i usually just run a wire directly from the motor through a switch to a suitable live. Long past patience with tricky hand bashing jobs on cars Sad
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Odd Issues with Rear Door Sensor
Last Post: GerardKeating
Today 12:27 AM
» Replies: 0
» Views: 5
Gearbox Fluid
Last Post: AlanS
Today 12:18 AM
» Replies: 14
» Views: 336
REAR AXCEL
Last Post: ajcommercial
Yesterday 11:57 PM
» Replies: 0
» Views: 11
Fuel Guage wrong
Last Post: ajcommercial
Yesterday 11:46 PM
» Replies: 2
» Views: 95
Longitudinal Roof rails on 2010 model
Last Post: Chrisville
Yesterday 08:42 PM
» Replies: 0
» Views: 31
radio code
Last Post: Tomcat3
Yesterday 07:14 PM
» Replies: 1
» Views: 42
Donation
Last Post: terryd999
Yesterday 06:15 PM
» Replies: 2
» Views: 41
Beeping with no error lights!!!
Last Post: sjparky
Yesterday 05:34 PM
» Replies: 11
» Views: 3761
Good Evening to you all.
Last Post: ron
Yesterday 04:33 PM
» Replies: 7
» Views: 213
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Yesterday 01:30 PM
» Replies: 3
» Views: 214

[-]
Recent Visitors
Locations of visitors to this page