Thread Rating:
  • 5 Vote(s) - 3.2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dashboard back light
#1
Hi all.
I am sure there is a thread on here about it however I haven't been able to find it.

I have a 2001 mrk 1 berlingo van and I've got no back lights on my dashboard and can't see anything when driving in the dark. All other warning lights work, I have taken the speedo cluster out but couldn't find any obvious of bulb.

Does any body know if I have missed something and there is a bulb or could it be a fuse?

Any help would be much appreciated.
Reply
#2
Have you got to push stalks in your speedo cluster? The one on the right sets the mileage and the left hand one is a dash brightness adjuster. Just a thought.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#3
Thanks for the reply, I was aware it does dim but it doesn't seem to work so that's what has lead me to believe that there is a possible bulb has gone.
Reply
#4
On later models I think the fuse is F2 and 5 amps but mk1 it could be F30 10a but this powers indicators and interior lights to. I think it has been mentioned on the forum that they may be soldered in led`s but I could be wrong and barking up the wrong tree. Try a search on the forum.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#5
Unless they've changed the design significantly between the 1999 and 2001 models, there's not one, but nearly half a dozen little 1.3W bulbs lighting up the dash. (I think it was 1.3W at least. Something in that area)
Multiple bulbs because it gives a more even illumination.

They're all held in with black 'twist off' holders that needs a quarter turn to lock/unlock. These holders can stick something fierce though, so pliers or other tool is a must. (Some may be under a piece that is held on with screws, too, if I remember correctly. )

But with no light at all, there's no chance that it's the bulbs. One or two gone, yes, but not all of them.

That leaves you with a fuse, broken cabling, faulty ground or an incompetent mechanic somewhere in the car's history.

Did it happen suddenly?
Reply
#6
It did yeah, parts of the dash lights didn't fail before others they all went together. So that may lead to the later causes.
Ill check the fuses tomorrow when it's light and if I get chance take it apart again and have a poke around and see if I can find the bulbs.
If I'm right in saying I think it was built in the change over year to the mrk 2s so I don't know if it'll be different to half a dozen bulbs you suggested?
I know my hub assembly isn't the same as a mrk 1 as I had to get a replacement from the scrap yard and a one off a mrk 1 didn't fit properly.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 30
Next gen berlingo multispace
Last Post: churmy
Yesterday 10:30 PM
» Replies: 0
» Views: 19
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1486
Is anyone buying a new car AFTER April 2017?
Last Post: Jed Clampit
Yesterday 09:25 PM
» Replies: 10
» Views: 174
Another seat belt question
Last Post: berreke
Yesterday 09:02 PM
» Replies: 1
» Views: 29
hi all
Last Post: Jed Clampit
Yesterday 08:39 PM
» Replies: 2
» Views: 37
Tyre Change...old on front new on back
Last Post: RocketVANman
Yesterday 08:26 PM
» Replies: 12
» Views: 195
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Yesterday 08:10 PM
» Replies: 8
» Views: 332
Newbie
Last Post: j.ted
Yesterday 08:03 PM
» Replies: 6
» Views: 101
Fuel rail pipe replacement
Last Post: Peter Palmer
Yesterday 04:50 PM
» Replies: 3
» Views: 88

[-]
Recent Visitors
Locations of visitors to this page