Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dashboard lightning & radio problem!
#1
Hey,

I bought a Citroen Berlingo MK1 1.9d, but i have no dashboard lightning at all (also not @the warming unit)
Is there a how-to how to fix this & wich bulbs are needed?
Hard job?

Also there was such an old radio it only has 2 cables whiles all modern radio's have more?
Someone experience in this?
Grtz
[-] The following 1 user says Thank You to LaZeR for this post:
  • addo
Reply
#2
It sounds like possibly the dash light circuit fuse has blown, if all lights are out.
Reply
#3
(12-08-2013, 11:36 AM)addo Wrote:  It sounds like possibly the dash light circuit fuse has blown, if all lights are out.

Only the warning blink button gives light.
I don't have to original Berlingo manual with the car, doess anyone have a fuse box schedule?
I already downloaded the manual on here but can't find it Confused
Reply
#4
Try fuse 19 under the dash; this applies to cars before ORGA (RPO) number 8500.
Reply
#5
It's possible that one or more connectors to the dash is loose, of course.

bulbs are 1.2W of those silly small 'Wedge' types:
http://biltema.no/ProductImages/35/large/35-15516_l.jpg
diameter is 5mm or so. bl**dy finnicky things, really.

In fact, they're such a pain to remove and insert that there's pliers built for the job:
http://biltema.no/ProductImages/19/large/19-1311_l.jpg

Same type of bulb is used for both warning lights and general illumination, and even the green light on the cigarette lighter, so having a few on hand doesn't hurt.
To get to them, or the connectors, though...
On models without AC, remove the triangular-ish vents(remove the box underneath, then feel for a tab at the 'pointed end' furthest from the dash to unlock it), then remove the screws holding the trim. Remove the coverings on the steering column(4 or 5 Torx screws on the underside) to get access to the final screws.
It's a bit of a pain...

Lets hope it's the fuse.
Reply
#6
Ok so i checked fuse 19, fuse is still ok.
I found another weird problem though while checking it, when the key is NOT in the ignition and i put my lights on my contact springs on w/o a key?
What problem is this .. :/
When i remove fuse 19 this doesn't happen.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Taking along time to heat up/warm the cabin
Last Post: Johny555
Today 06:55 PM
» Replies: 4
» Views: 69
Next gen berlingo multispace
Last Post: wildoat
Today 06:24 PM
» Replies: 10
» Views: 201
clunky gear change
Last Post: Hora
Today 05:23 PM
» Replies: 1
» Views: 34
Tyre Change...old on front new on back
Last Post: ricc
Today 05:15 PM
» Replies: 13
» Views: 249
Mesh Bulkhead
Last Post: Jelevents
Today 03:13 PM
» Replies: 3
» Views: 66
Supermarket Diesel
Last Post: geoff
Today 03:06 PM
» Replies: 5
» Views: 93
longitudinal roof rails
Last Post: Corker
Today 02:48 PM
» Replies: 1
» Views: 53
Finally a B9 Haynes Manual
Last Post: Corker
Today 02:38 PM
» Replies: 42
» Views: 2536
Slow starter (diesel)
Last Post: ricc
Today 11:53 AM
» Replies: 15
» Views: 354
2005 Berlingo
Last Post: len glover
Today 10:10 AM
» Replies: 6
» Views: 105

[-]
Recent Visitors
Locations of visitors to this page