Thread Rating:
  • 6 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ELECTRIC TROUBLES
#1
WENT TO GET IN VAN OTHER NIGHT KEY FOB NOT WORKING GOT IN VAN USING KEY, PUT KEY IN IGNITION AND EVERY LIGHT ON DASHBOARD CAME ON PLUS HEAD LIGHTS WHICH I COULD NOT TURN OFF FROM SWITCH, COULD NOT GET IMMOBILE OFF, TRIED TURNING ENGINE OVER BUT IT WAS AS IF BATTERY WAS FLAT,HAD TO GET A TOW HOME, OF COURSE IT WAS POURING WITH RAIN AT MOMENT VAN JUST SITTING ON DRIVE, ANY HELP PLEASE.
Reply
#2
Modern electrics are beyond me, but if I had this problem I would disconnect the battery, then go back indoors for an hour and have a beer. I'd then reconnect the battery and see how it looked then. No doubt someone with more knowledge than me will be along shortly.
Good luck.
'56 Multispace 1.6HDi - Iron Grey
Reply
#3
(03-11-2012, 04:51 PM)TOPDECS Wrote:  TRIED TURNING ENGINE OVER BUT IT WAS AS IF BATTERY WAS FLAT,

Have you checked the battery voltage yet? or did you try jumpstarting it?

I'd disconnect the battery, check the voltage, charge the battery if it needs it, then reconnect the battery (search on this froum for BSI reset precedure, basically the cars ecu might need resetting).

The only time something like this has happened to me was when a fuse had blown, once the fuse was replaced and the ecu reset it was fine.

The fact you mentioned it was pouring with rain makes me think that perhaps water has got into somewhere it shouldn't have and is causing problems.
Reply
#4
Firstly, can you please stop typing in CAPITALS, as it very difficult to read, and in internet forum terms insinuates shouting! Thanks.

Secondly, if all the lights came on when you inserted the key, it would indicate a short in the system, as many of the circuits would normally be isolated through various switches, or circuits within the ECU.

I would locate the ECU and check to see if anything has got wet there. If it has, it may have shorted out the ECU, which will probably require replacing. If it doesnt appear that rain is the issue, then the next option is chasing the route of the main ignition wiring throughout the car to locate any chaffed, split or broken wiring.
Reply
#5
(03-11-2012, 09:24 PM)LowLingo Wrote:  Firstly, can you please stop typing in CAPITALS, as it very difficult to read, and in internet forum terms insinuates shouting! Thanks.

Secondly, if all the lights came on when you inserted the key, it would indicate a short in the system, as many of the circuits would normally be isolated through various switches, or circuits within the ECU.

I would locate the ECU and check to see if anything has got wet there. If it has, it may have shorted out the ECU, which will probably require replacing. If it doesnt appear that rain is the issue, then the next option is chasing the route of the main ignition wiring throughout the car to locate any chaffed, split or broken wiring.

Sorry for all the capital letters.
Had a dianostic check yesterday and the chap could not get areading he reckons the ecu has gone am going to have a chat with my Citron dealer tomorrow to see how much if it can be fixer, fingers crossed.

(03-11-2012, 05:52 PM)pidgeonpost Wrote:  Modern electrics are beyond me, but if I had this problem I would disconnect the battery, then go back indoors for an hour and have a beer. I'd then reconnect the battery and see how it looked then. No doubt someone with more knowledge than me will be along shortly.
Good luck.

Tried that still no different, thanks for reply

(03-11-2012, 09:24 PM)LowLingo Wrote:  Firstly, can you please stop typing in CAPITALS, as it very difficult to read, and in internet forum terms insinuates shouting! Thanks.

Secondly, if all the lights came on when you inserted the key, it would indicate a short in the system, as many of the circuits would normally be isolated through various switches, or circuits within the ECU.

I would locate the ECU and check to see if anything has got wet there. If it has, it may have shorted out the ECU, which will probably require replacing. If it doesnt appear that rain is the issue, then the next option is chasing the route of the main ignition wiring throughout the car to locate any chaffed, split or broken wiring.
can the ECU be reset or is it a new one plus any idea how much?
Reply
#6
Hi, Start with the basics.
Check that the battery is charged.
Check both main terminal connections and the chassis earth + the gearbox earth.
Check all the fuses in the BSI (as mentioned) + the engine bay fuse box.
Your engine should still turn over with the key. If it's not then there could be a problem with :
Your battery, starter motor or solenoid or the connections from your battery to s/motor etc or earths.
Let us know what the results are. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Head Light Bulbs
Last Post: dargoion
Today 05:52 PM
» Replies: 33
» Views: 977
radio code
Last Post: Tomcat3
Today 02:32 PM
» Replies: 3
» Views: 80
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Trevor
Today 02:13 PM
» Replies: 2
» Views: 38
Removing the rear roof storage bin (mk3 modutop)
Last Post: iscom
Today 01:31 PM
» Replies: 15
» Views: 6739
display fading (MFD B, not bulb related)
Last Post: saskak
Today 01:02 PM
» Replies: 41
» Views: 6100
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 12:13 PM
» Replies: 4
» Views: 243
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 12:07 PM
» Replies: 1
» Views: 60
Rear light bulb holders - keeps dropping bulb.
Last Post: Top drive
Today 12:01 PM
» Replies: 7
» Views: 296
What website to pass time over a winters evening...
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 1
» Views: 253
Good Evening to you all.
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 8
» Views: 233

[-]
Recent Visitors
Locations of visitors to this page