Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Electric Problem.
#1
Hi.
Well all was going well with my 2005 1.9D Berlingo Van when, I fitted an after market stereo off eBay but couldn't get the audio settings to save, forums suggested swopping the red and yellow wire around which I did and all was great. Audio settings saved, great I thought. Went to the van 6 hours later and everything was all over the shop, windscreen wipers on when I hadn't turned them on, something sounded to be clicking under the bonnet when I tried turning the ignition on, dash lights, then no dash lights. Then pulled the key out of the ignition, made sure lights in off position and side lights are on all round, (barely).
Tried jump leads to no gain and this does not sound to be a flat battery.
Getting it recovered in the morning but does anyone have any idea what this problem might be? (and whether it was the stereo or not, its out of there).
Thank you.
Reply
#2
You need to do a bsi reset as your have electrics have thrown a wobbler. When you work on the electrics on a citroen you need to disconnect the battery so as not to muck up the BSI ( body system interface). Have a search on the forum for the procedure or have a look here http://www.bba-reman.com/content.aspx?co...ot_process
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#3
Hi.
I tried the above, thought I was in business. Tried headlights first on and off without a key, yes. Tried turning ignition and had some dash lights initially but a lot of clicking from under the bonnet like it was shorting on something. Wouldn't start and then lost all the dash lights.
Reply
#4
You need to shut everything down and disconnect the battery then follow the reset procedure if you havnt got central locking just skip that bit. If the radio is still connected disconnect that before you start.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#5
Done it, lights work. But as soon as I try to turn ignition on all I'm getting is the clicking noise under the bonnet and now for some reason wipers came on very slowly mind.
Reply
#6
You could try disconnecting the battery and leaving it for a few hours then try a reset. You may have done damage to the BSI unit which controls all the electrical component's. Its under the fuse box to the right of the steering wheel and can be checked out. They are prone to water ingress which causes problems but if it only started when you did the radio it that is more than likely the problem.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#7
Your battery is flat you need to give it a good long charge
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#8
Not a flat battery as the jump leads should have started it and a flat battery wouldn't put my side lights on for no apparent reason. Thanks anyway though.
Reply
#9
I take it all back Jed, breakdown came out to it this morning and yes it was indeed a flat battery, I asked him why would a flat battery set windscreen wipers off, lights etc and he said for some unexplained reason a low battery causes havoc with the relays and tells them to do all manner of things. The battery on it was too small also, fingers crossed this is all it is now I've put a new battery on it. Thanks for advise re BSI, that was a sensible answer too.
Reply
#10
(16-07-2015, 09:52 AM)SpeedyJD Wrote:  I take it all back Jed, breakdown came out to it this morning and yes it was indeed a flat battery, I asked him why would a flat battery set windscreen wipers off, lights etc and he said for some unexplained reason a low battery causes havoc with the relays and tells them to do all manner of things. The battery on it was too small also, fingers crossed this is all it is now I've put a new battery on it. Thanks for advise re BSI, that was a sensible answer too.

Smile Glad you got it sorted the wiper's coming on was the give away
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
BULBS!!
Last Post: Jed Clampit
Yesterday 11:05 PM
» Replies: 17
» Views: 549
Finally a B9 Haynes Manual
Last Post: Satellitemark
Yesterday 10:43 PM
» Replies: 39
» Views: 2470
clunking noise
Last Post: Silverberlingo
Yesterday 10:35 PM
» Replies: 4
» Views: 60
TRAILER WANTED
Last Post: Silverberlingo
Yesterday 10:29 PM
» Replies: 4
» Views: 74
longitudinal roof rails
Last Post: Chrisville
Yesterday 10:27 PM
» Replies: 0
» Views: 17
Head Light Bulbs
Last Post: Hughzie
Yesterday 09:23 PM
» Replies: 36
» Views: 1131
Newbie
Last Post: Jed Clampit
Yesterday 08:37 PM
» Replies: 6
» Views: 86
first time ctroen owner
Last Post: Jed Clampit
Yesterday 08:25 PM
» Replies: 1
» Views: 34
M59 Cooling system change PDF
Last Post: coatess
Yesterday 06:46 PM
» Replies: 1
» Views: 209
What to look for when buying?
Last Post: polar
Yesterday 06:16 PM
» Replies: 6
» Views: 74

[-]
Recent Visitors
Locations of visitors to this page