Thread Rating:
  • 4 Vote(s) - 2.25 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Electrical issues
#1
New to the Berlingo/partner world but definetly not new from the Psa scene previously owning 306dt power 170bhp+

The van is a s reg 1.9d
Any way issues I have

1
Windscreen wipers work only at full speed once at full speed I can knock it to the next speed but it will judder and go slow almost stopping and some cases actually stopping but I can still hear the relay clicking. When this happens the moror clicks and bangs like its lose. I also have no washer jets iv tested the pump which works fine I have no power going to it. The wipers also don't work.

I'm figuring that a new stalk and wiper motor will cure this. How ever it has once perfectly worked fine smooth operation on all speeds but still no washer jets.

2
Interior fans don't work at all I'm suspecting the resistor back to be the problem here.

3
Every time I turn the car off my CD player resets as if there isn't a memory live. The CD player worked perfectly fine in my previous car.

Iv checked fuses and checked things over with a multimeter and advice pointers will be great.

Cheers
Reply
#2
Hi there it sounds like your blower resistor pack is dead and if its an aftermarket radio and you wired it in I would say you havn`t put a permanant live to it. Plenty on here about what wires to change over or patch leads. Your wiper/stalk problem does sound like the stalk has worn on the contact traces. Ive had this happen on mercs and renaults over the years.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#3
Cheers for the Info regards stereo it's a plug and play one no wires needed to cut just plugs into the exhausting loom

Cheers
Reply
#4
(28-05-2013, 09:39 AM)Jenkosowls Wrote:  Cheers for the Info regards stereo it's a plug and play one no wires needed to cut just plugs into the exhausting loom

Cheers

Best have a lie down after you've done it then :lol:
So where does this bit go then ?
[-] The following 1 user says Thank You to ffrenchie for this post:
  • addo
Reply
#5
You better have a read up on the radio issues because a few have done as you say and I think they had problems and had to swap a wire round to get round it. Im sure one of the members will pass by and let you know which wires to swap.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#6
(28-05-2013, 11:32 AM)ffrenchie Wrote:  
(28-05-2013, 09:39 AM)Jenkosowls Wrote:  Cheers for the Info regards stereo it's a plug and play one no wires needed to cut just plugs into the exhausting loom

Cheers

Best have a lie down after you've done it then :lol:

Haha ifails for you!
Reply
#7
The new head unit should have yellow and red wires with a pull apart connector in a sleive.

Swap these over so the red feeds the yellow and then retest.
[-] The following 1 user says Thank You to tucker for this post:
  • Jenkosowls
Reply
#8
(28-05-2013, 09:41 PM)tucker Wrote:  The new head unit should have yellow and red wires with a pull apart connector in a sleive.

Swap these over so the red feeds the yellow and then retest.

Did This and it solved that problem thumbs up
Reply
#9
Currently still having the wiper problem. I swoped the stalk off my old 306 the only difference being it has rear wiper function. Now this to also didnt work so can rule the stalk out as the problem. It only worked on full when pressing the stalk down fir single wiper operation it didnt work either. If I pulled the stalk towards me on a 306 it operates washer jets they worked except didn't operate the wipers.

I cleaned up the contacts inside the Berlingo stalk but still having the same problem. Except I tried the stalk out of the cowling pulled it like I did on the 306 and it operated the washer jets but no wipers. It appears the cowling restricts the stalk to up and down movement only. So I can rule out the stalk now it's something else
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
radio code
Last Post: Tomcat3
Today 02:32 PM
» Replies: 3
» Views: 70
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Trevor
Today 02:13 PM
» Replies: 2
» Views: 32
Removing the rear roof storage bin (mk3 modutop)
Last Post: iscom
Today 01:31 PM
» Replies: 15
» Views: 6736
display fading (MFD B, not bulb related)
Last Post: saskak
Today 01:02 PM
» Replies: 41
» Views: 6097
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 12:13 PM
» Replies: 4
» Views: 238
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 12:07 PM
» Replies: 1
» Views: 56
Rear light bulb holders - keeps dropping bulb.
Last Post: Top drive
Today 12:01 PM
» Replies: 7
» Views: 293
What website to pass time over a winters evening...
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 1
» Views: 248
Good Evening to you all.
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 8
» Views: 230
REAR AXCEL
Last Post: Top drive
Today 10:45 AM
» Replies: 2
» Views: 50

[-]
Recent Visitors
Locations of visitors to this page