Thread Rating:
  • 6 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] 2.0 HDi Revving uncontrollably
#1
I'd be really grateful for some advice here.

A few days ago the OH took our 2004 2.0 HDi out for a drive, and on the way back the engine suddenly began to rev without her putting her foot on the accelerator - masses of black smoke from the exhaust too. She was able to pull over and turn the engine off, but was very scared by it. She called me. Luckily it was a small and straight road with very little traffic.

When I arrived 25 minutes later I started the car - perfectly normally - and drove it home. Nothing like that happened again.

A day or two later on a long downhill drive - about 3 miles with the engine on overrun in third gear all the way, just using the brakes at corners - the engine management light lit up on the dash. There were no other symptoms - the car seemed to drive perfectly well.

When the car cooled down and restarted the light stayed off (and it still is).

Should I be biting my nails and expecting something really awful to happen soon? I wouldn't fancy the first fault if it happened on a motorway, for example! Could this be something to do with the EGR? Any suggestions at all about what might be wrong?
Reply
#2
It sounds as though your engine is feeding on its own oil. You'd need to investigate whether its coming through failed seals in the turbo, or the crankcase breather system.
Reply
#3
(16-07-2013, 11:09 AM)addo Wrote:  It sounds as though your engine is feeding on its own oil. You'd need to investigate whether its coming through failed seals in the turbo, or the crankcase breather system.

Thanks Addo. It has only happened once. If it were failed seals in the turbo, wouldn't I expect it to happen (for example) whenever I accelerate hard? And would I expect it to be using oil? (as it doesn't seem to be). Not water either.

That said, the exhaust does always seem a bit smelly - not smoky, just a smell. But I rather thought that was just normal for a diesel.
Reply
#4
Just a short update. I never did find out what had caused this, not for certain, but I think - with hindsight - the engine oil level was probably excessive and it was a hot day: I'm guessing oil was pulled into the engine via the sump breather (if that is possible?). In any event, I had the oil changed and refilled to the correct level, and, several thousand miles later, nothing similar has recurred.

The engine is still a bit smelly (not smoky) at times and I'd guess that IS the EGR. But I'm told blanking it off is difficult with the 2.0 HDi.
[-] The following 1 user says Thank You to Araucaria for this post:
  • brodfather11
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Taking along time to heat up/warm the cabin
Last Post: Johny555
Yesterday 11:13 PM
» Replies: 6
» Views: 122
New tablet fitted
Last Post: Washeymag
Yesterday 11:11 PM
» Replies: 0
» Views: 22
1.6hdiTurbo Over Boost OBD code P0234
Last Post: berlingo16hdif
Yesterday 11:00 PM
» Replies: 11
» Views: 14438
Supermarket Diesel
Last Post: Silverberlingo
Yesterday 08:26 PM
» Replies: 6
» Views: 129
2005 Berlingo
Last Post: len glover
Yesterday 07:23 PM
» Replies: 7
» Views: 120
Next gen berlingo multispace
Last Post: wildoat
Yesterday 06:24 PM
» Replies: 10
» Views: 229
clunky gear change
Last Post: Hora
Yesterday 05:23 PM
» Replies: 1
» Views: 49
Tyre Change...old on front new on back
Last Post: ricc
Yesterday 05:15 PM
» Replies: 13
» Views: 267
Mesh Bulkhead
Last Post: Jelevents
Yesterday 03:13 PM
» Replies: 3
» Views: 79
longitudinal roof rails
Last Post: Corker
Yesterday 02:48 PM
» Replies: 1
» Views: 69

[-]
Recent Visitors
Locations of visitors to this page