Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] 2011 Injector leaking (1.6)
#1
Need some advice please.

I smelt some diesel and checked the engine. I think that No 4 injector is leaking, or was, I'm not sure what it is, but the small black clip on top of the little green thing that goes into the top of the injector was up, I pressed it down and it clipped into place.

I'm hoping this has solved the problem.

I can't work out how it possibly got loose, no ones been in there for ages.

Is this a known thing?


In searching for any answers I came across the thread about loose bolts on the injector housing, I was just about able to check the rear ones, but can't hardly even see the front ones and all the photos I've seen, seem different from my engine.
Mine doesn't have the plastic cover to just take off, but a flexible material type thing.
Any ideas how I get to the bolts?

Thanks Smile
Reply
#2
please show us som pictures.

The bolts holding down the nozzle is a big problem on these cars i have found out. on my car all of them was loose.
to access the nuts behind the injectors. you have to loosen the plastic thingy on top of the engine. 2 torx i think

0.34 you see the big plastic thing with cables inside you have to loosen https://www.youtube.com/watch?v=-BI5HnuI5-Y
Reply
#3
My engine is different to the one pictured in the video. My injectors seem on the other side of the engine and much harder to access.
Hope these photos come out.

The 2nd photo is the injector in which the top bit was up and I clicked it down again.


Attached Files Thumbnail(s)
               
Reply
#4
Looks like you may have a leak off leak as apposed to an injector seat leak?

Do you have any black oil/tar around any of the injectors as they go into the head?

When the engine is running can you see any smoke coming out from around the injectors or hear any chuffing? Try a mixture of washing up liquid mixed with water and paint it around the injector body to test for gas blow by if you are not sure. Remember to wash it off afterwards as it is full of salt!
Reply
#5
Yeah I am hoping that it was a "leak off" leak. They don't seem very well fitted to the injector, very easy to get them off.

I couldn't hear any chuffing. I will have to keep a close eye on it. But it's really difficult to see the injectors properly, as you can probably see.
Reply
#6
No diesel smell this morning when I dropped the kids at school, but 10 mins later at home, smelt it again and sure enough the black clip is up again. It clicked back again sturdily enough, but I'm really confused now.
How can that happen? Any ideas please?
Reply
#7
Well, I've just clicked it back in and turned the engine on, it vibrates out almost immediately. You can see it come out as soon as you turn the engine on.

So is the clip at fault, or is there some pressure forcing it out?
Reply
#8
(15-06-2015, 08:04 AM)Hairbear Wrote:  Well, I've just clicked it back in and turned the engine on, it vibrates out almost immediately. You can see it come out as soon as you turn the engine on.

So is the clip at fault, or is there some pressure forcing it out?


I would check to see if the leak off pipe could be pinched closed by some other fixing somewhere, which might cause pressure build-up within it.
Reply
#9
(15-06-2015, 10:43 AM)CourierJim Wrote:  I would check to see if the leak off pipe could be pinched closed by some other fixing somewhere, which might cause pressure build-up within it.
Thanks Jim. No it's not that.

I've managed to wedge the black bit in, but it still seems to be leaking from around the leak off connection.
It's too hot at the moment to get in there, I'll have to have a better look in the morning.

Considering I know nothing about leak off stuff, is there anything I need to know.
Reply
#10
IT may pay you to get a new leak off rail set from Citroen, it comes as a complete kit for all four injectors and its not that expensive. Why its come off is any bodies guess but the o rings may be damaged now, is the van still under warranty?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Help needed have immobiliser fault and fan probl...
Last Post: Dennyboy
Today 01:02 PM
» Replies: 0
» Views: 5
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Andre
Today 11:23 AM
» Replies: 2
» Views: 198
Lucas mechanic fuel pump - disassembly and timin...
Last Post: yanivh
Today 11:01 AM
» Replies: 0
» Views: 26
Head Light Bulbs
Last Post: Tree
Today 08:38 AM
» Replies: 32
» Views: 900
EGR solenoid
Last Post: silver-slug
Today 08:31 AM
» Replies: 19
» Views: 1426
ABS Modul
Last Post: brajomobil
Today 08:07 AM
» Replies: 2
» Views: 106
Speedo/milometer fault
Last Post: Gixxerguyk8
Today 12:28 AM
» Replies: 15
» Views: 1456
Which wheel nuts?
Last Post: Stu999
Yesterday 11:50 PM
» Replies: 0
» Views: 54
VAN SECURITY
Last Post: ricc
Yesterday 08:29 PM
» Replies: 5
» Views: 177
Clanking Brake Pedal Solved At Last!
Last Post: rickandbev16
Yesterday 06:53 PM
» Replies: 17
» Views: 3446

[-]
Recent Visitors
Locations of visitors to this page