Thread Rating:
  • 11 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Black Smoke
#1
Hi,

I have a 2004 MK2 Berlingo 1.9d. Since I bought the van in May I have had a constant problem of the van kicking out black smoke at around 2,250 revs and under load. Been to garage 10 times now, had new air mass, new Cat, new EGR. Still misfire and black smoke at just over 2,000 revs under load. Van has had full service all filters, runs better if I remove cable to Airmass, which is odd. The van is immaculate otherwise it would have gone by now. It starts fine. Please could someone give me a clue to what could be causing this. Thank you.
Reply
#2
Could there be a possibility that the new air mass is faulty , I bought one for a scenic once which was faulty from new
Reply
#3
The first thing you have to do is to change your garage!
There is way too much of this bad diagnostics crap going on.
They were employed by you to fix a specific fault and judging by
your post here they haven't yet fulfilled their side of the contract.
But I'll bet it's cost you some fairly serious money to have them
do all of that part-changing and you won't see that again.
Excuse the rant but don't they take the vehicle for a test drive
when they think that the fault is cured? I would be demanding some
recompense at least. If you had done the work yourself you wouldn't
have done much worse. You need to have a chat with the proprietor
of the company.
The Older I get the Better I Was!  Cool
Reply
#4
What OJ says.

A garage that just keeps changing parts in the hope that it will eliminate a problem does not deserve to be in business.

I would be returning to them and giving them a letter along the lines that you have asked them to deal with a problem but despite charging you £x the problem remains and that you consider rthis to be a breach of contract. You should then be giving them 14 days to resolve the matter to your satisfaction or providing you with a refund.

Then find a local independent from a recommendation.

I realise that this can be awkward, but they are taking money from you and not providing the service
Reply
#5
What Coco says.
100%. :thumbsup:
Reply
#6
(25-10-2012, 06:10 PM)j90xxx Wrote:  What Coco says.
100%. :thumbsup:

Yup, ten visits and still not fixed? I'd have found a new garage LONG before then!
Somedays you're the pigeon, Somedays you're the statue.
Reply
#7
I see no mention of testing the injectors which,with the symptoms,I find a bit wierd.
Strawberry flavoured windows  Dodgy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Head Light Bulbs
Last Post: Tree
Today 08:38 AM
» Replies: 32
» Views: 858
EGR solenoid
Last Post: silver-slug
Today 08:31 AM
» Replies: 19
» Views: 1398
ABS Modul
Last Post: brajomobil
Today 08:07 AM
» Replies: 2
» Views: 89
Speedo/milometer fault
Last Post: Gixxerguyk8
Today 12:28 AM
» Replies: 15
» Views: 1420
Which wheel nuts?
Last Post: Stu999
Yesterday 11:50 PM
» Replies: 0
» Views: 37
VAN SECURITY
Last Post: ricc
Yesterday 08:29 PM
» Replies: 5
» Views: 154
Clanking Brake Pedal Solved At Last!
Last Post: rickandbev16
Yesterday 06:53 PM
» Replies: 17
» Views: 3419
Good Evening to you all.
Last Post: Tomcat3
Yesterday 05:06 PM
» Replies: 6
» Views: 159
Are Mud Flaps the Answer ?
Last Post: polar
Yesterday 05:06 PM
» Replies: 3
» Views: 108
Slow starter (diesel)
Last Post: zedhead
Yesterday 10:09 AM
» Replies: 10
» Views: 248

[-]
Recent Visitors
Locations of visitors to this page