Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] EML / Loss of performance
#1
Hi chaps and chapesses. My '04 Partner 2.0 HDI is playing silly buggers, EML light on, Very rough Idle when I fired it up this morning and only making half its normal boost.Sounding/performing like an old Transit van. Has it gone into safe mode? Its a seimens ECU BTW and I have no code reader. Would it still be OK to get to work tomorrow? Cheers in advance
'04 Peugeot Partner HDi LX. Lows, Leaks and Wellers. Now matt grey and dent free Smile

Reply
#2
PS sorry for the small font god knows what happened there!
'04 Peugeot Partner HDi LX. Lows, Leaks and Wellers. Now matt grey and dent free Smile

Reply
#3
Look's like the egr not working properly or an injector glow plug on it's way out
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
[-] The following 1 user says Thank You to Jed Clampit for this post:
  • PeteA
Reply
#4
Sorted it now cheers, turned out to be the tuning box unplugged that and it seems fine now. Blanked off the EGR years ago and did the glow plugs afew months back. Do think an injector is duff though it misfires under load at 1500 rpm has done for years...I just live with it lol. Getting a Caddy soon all being well fancy something more refined Smile
'04 Peugeot Partner HDi LX. Lows, Leaks and Wellers. Now matt grey and dent free Smile

Reply
#5
Glad you got it sorted.  Don't tell me it's a 20L HDI i think a lot of them do it  Smile
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Is anyone buying a new car AFTER April 2017?
Last Post: doofer
Today 03:02 PM
» Replies: 0
» Views: 5
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 02:55 PM
» Replies: 6
» Views: 280
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: rickandbev16
Today 02:12 PM
» Replies: 4
» Views: 88
Finally a B9 Haynes Manual
Last Post: rickandbev16
Today 02:04 PM
» Replies: 32
» Views: 2137
Are Mud Flaps the Answer ?
Last Post: doofer
Today 12:41 PM
» Replies: 10
» Views: 270
Head Light Bulbs
Last Post: doofer
Today 09:38 AM
» Replies: 35
» Views: 1063
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Bob Southey
Today 07:43 AM
» Replies: 3
» Views: 278
REAR AXCEL
Last Post: ajcommercial
Yesterday 09:36 PM
» Replies: 3
» Views: 102
Odd Issues with Rear Door Sensor
Last Post: dumdum
Yesterday 09:25 PM
» Replies: 1
» Views: 79
display fading (MFD B, not bulb related)
Last Post: sks01773
Yesterday 07:50 PM
» Replies: 42
» Views: 6167

[-]
Recent Visitors
Locations of visitors to this page