Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Ignition stuck on
#1
Hi,
I'm looking at a Berlingo where the ignition couldn't be turned off.
The owner was stopping it by stalling it then removing the battery terminal.

So far...
I've verified that the ignition switch is doing what it's supposed to in the relevant positions.

On the BSI, the central grey 2-pin plug has a positive feed on each pin - white wire and brown wire.
If I unplug that connector, the ignition switch functions normally as far as the engine is concerned, but I get no "accessory" feeds.
If I probe the connector on the BSI, I get a feed on one of those pins with the ignition switch in position 2.

I've had a look at the wiring diagrams which seem to imply that both of those wires are indeed feeds to the BSI but are fed from a separate part of the engine fuse box.
If that's the case, I need to pull some individual circuit fuses to see which is backfeeding - or if the fault is internal to the BSI itself.

Please can someone clarify if indeed those two wires should both be permanent feeds in, or whether one should be a feed back out - the internal block diagrams for these modules don't give much clue about power control and distribution.

Any help appreciated, it will save me some time when I have a look at it again tomorrow.

Thanks,

Simon.
Reply
#2
What year/ engine is your berlingo, ?. Sometimes helps.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Is anyone buying a new car AFTER April 2017?
Last Post: doofer
Today 03:02 PM
» Replies: 0
» Views: 5
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 02:55 PM
» Replies: 6
» Views: 280
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: rickandbev16
Today 02:12 PM
» Replies: 4
» Views: 88
Finally a B9 Haynes Manual
Last Post: rickandbev16
Today 02:04 PM
» Replies: 32
» Views: 2137
Are Mud Flaps the Answer ?
Last Post: doofer
Today 12:41 PM
» Replies: 10
» Views: 270
Head Light Bulbs
Last Post: doofer
Today 09:38 AM
» Replies: 35
» Views: 1063
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Bob Southey
Today 07:43 AM
» Replies: 3
» Views: 278
REAR AXCEL
Last Post: ajcommercial
Yesterday 09:36 PM
» Replies: 3
» Views: 101
Odd Issues with Rear Door Sensor
Last Post: dumdum
Yesterday 09:25 PM
» Replies: 1
» Views: 79
display fading (MFD B, not bulb related)
Last Post: sks01773
Yesterday 07:50 PM
» Replies: 42
» Views: 6167

[-]
Recent Visitors
Locations of visitors to this page