Thread Rating:
  • 4 Vote(s) - 3.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Mystery misfire on 1.6 Diesel
#1
Hi,
I don't know if any one has experienced this and can help me:
When driving 1.6 hdi 92bhp (2006) in hot weather, or in slow moving traffic my engine temp. begins to rise. When it reaches about 88, the engine misfires and stops. Given 10 minutes, the engine will restart but if the traffic doesn't move smartly, the engine will cut out again.
It has cut out when going up hill, too.
Diesel used is clean and commercial. Local citroen dealer suggested my driving, but it also happens with my husband; also suggested journeys too short, but happens on journeys of over 100 miles. Have had checked out elsewhere but to no avail.
Would be very grateful for any helpful comments
Reply
#2
Hi I can't help you with your problem but what has amazed me is the dealer suggesting it's your driving.
Reply
#3
It could be many things but i'm thinking low pump pressure?

How many miles has it done?
Reply
#4
Your problem is most likely one of the injectors, (the 1.6 hdi does not have a low pressure pump)
I would recommend a diesel leak off test, most likely that one of the injectors is faulting at that temp, hence the rail pressure just drops off, then it will restart when cooled off.
The stealers will not be able to diagnose it without spending thousands of your pounds and playing "parts darts".
I assuMe you have changed the diesel filter, don't think it will be the issue, but always a good start.
Would be easy to run the engine looking at parameters on Lexia, and see what happens at 88degrees, it will surely loose fuel pressure or crank signal. If the rev signal switches off, could indicate crank sensor, a new one is only about £20.
Reply
#5
LOL at "parts darts". I call it "swap and pray".
Reply
#6
(29-08-2013, 07:58 PM)Lighty Wrote:  Your problem is most likely one of the injectors, (the 1.6 hdi does not have a low pressure pump)
I would recommend a diesel leak off test, most likely that one of the injectors is faulting at that temp, hence the rail pressure just drops off, then it will restart when cooled off.
The stealers will not be able to diagnose it without spending thousands of your pounds and playing "parts darts".
I assuMe you have changed the diesel filter, don't think it will be the issue, but always a good start.
Would be easy to run the engine looking at parameters on Lexia, and see what happens at 88degrees, it will surely loose fuel pressure or crank signal. If the rev signal switches off, could indicate crank sensor, a new one is only about £20.

Thank you for your suggestions. Filter changed regularly and recently and an injector changed before in a previous attempt to survive summer. I will get the Lexia test done. It would be great if it was the crank sensor.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Help needed have immobiliser fault and fan probl...
Last Post: Dennyboy
Today 10:21 AM
» Replies: 2
» Views: 99
After market cruise control
Last Post: cancunia
Today 10:13 AM
» Replies: 7
» Views: 565
TRAILER WANTED
Last Post: ffrenchie
Today 09:28 AM
» Replies: 2
» Views: 42
brake warning light
Last Post: lenoldboy
Today 09:01 AM
» Replies: 0
» Views: 27
touchscreen firmware version
Last Post: manelux
Today 08:46 AM
» Replies: 2
» Views: 291
Newbie
Last Post: Andre
Today 08:29 AM
» Replies: 4
» Views: 57
Highest milage on a mk3
Last Post: Hora
Today 02:54 AM
» Replies: 51
» Views: 11006
Just to say hi
Last Post: polar
Today 02:29 AM
» Replies: 4
» Views: 88
2005 Berlingo
Last Post: polar
Today 02:27 AM
» Replies: 5
» Views: 74
Are Mud Flaps the Answer ?
Last Post: andylobb
Yesterday 09:51 PM
» Replies: 14
» Views: 431

[-]
Recent Visitors
Locations of visitors to this page