Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Overheating....I think?
#1
Evening All,

Im a noob to the forum so you will have to bear with me.

Im driving along happily in my 2000 1.9D Berlingo when the temperature gauge drops and it starts to make a metallic rattle when applying the accelerator. I thought it was an issue with the coolant sensor but i dont think it is that as the temperature was showing fine until the rattle started. 

I will say that it drives fine once cool and the rattle only starts when the   driving about for 30 mins or stuck in traffic. I read a previous post saying that it could be a sticky thermostat but i really want to ask you all your opinions before ripping the Berlingo apart.

Any help is greatly as its doing my nut in trying to find this fault. Im running out of places to go to try and replicate the fault.
Reply
#2
Hi, First things first - Is your coolant level ok and the system free of air locks? When the problem occurs is the top radiator hose rock hard? Does the fan/s kick in?
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#3
(16-06-2016, 05:08 PM)Landmark Wrote:  Hi, First things first - Is your coolant level ok and the system free of air locks? When the problem occurs is the top radiator hose rock hard? Does the fan/s kick in?
Griff

Cheers for your reply Griff

.Coolant level is fine. System recently went in for a service, coolant replacement and system was bled. The top radiator hose was rock hard now you mention it. Do you suspect head gasket?
Reply
#4
Sorry the car went in for a service, not the system and the fans do kick in
Reply
#5
The temp gague will drop to zero if there is no water for it to read due to loss or air lock. The fact it rattles worries me -almost as if it's seizing.
I'm sure the more knowledgable will be along soon as we had the petrol version.
If you're 100% certain the coolant system is ok (coolant/thermostate/radiator/water pump/fans) then I'd try a new temp sensor.
The top hose being rock hard could be a couple of things including the head gasket, but a garage can do a "sniff Test" for combustion gases in the coolant.
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#6
Thanks again Griff. I got bored over the weekend so I replaced coolant temp sensor, thermostat and coolant. I know I lead a hard life. I've also bled the system with new coolant. Still having the same problem. I suspected the head gasket but I have noticed the rattling only comes on when I use the accelerator. When I'm engine breaking the rattle isn't there at all!!! This is starting to get really confusing now. Temperature gauge shuts off and the rattle starts when accelerating. Thinking injector?
1.9D Mk1 Berlingo 2000
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Longitudinal Roof rails on 2010 model
Last Post: Chrisville
Today 08:42 PM
» Replies: 0
» Views: 19
radio code
Last Post: Tomcat3
Today 07:14 PM
» Replies: 1
» Views: 31
Donation
Last Post: terryd999
Today 06:15 PM
» Replies: 2
» Views: 36
Beeping with no error lights!!!
Last Post: sjparky
Today 05:34 PM
» Replies: 11
» Views: 3758
Good Evening to you all.
Last Post: ron
Today 04:33 PM
» Replies: 7
» Views: 206
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Today 01:30 PM
» Replies: 3
» Views: 204
Help needed have immobiliser fault and fan probl...
Last Post: Dennyboy
Today 01:02 PM
» Replies: 0
» Views: 37
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Andre
Today 11:23 AM
» Replies: 2
» Views: 230
Lucas mechanic fuel pump - disassembly and timin...
Last Post: yanivh
Today 11:01 AM
» Replies: 0
» Views: 37
Head Light Bulbs
Last Post: Tree
Today 08:38 AM
» Replies: 32
» Views: 933

[-]
Recent Visitors
Locations of visitors to this page