Thread Rating:
  • 5 Vote(s) - 2.4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine failure
#1
Sad 
Oh dear! the engine on my son's 2002 1.9D Multispace went bang and left bits all over the drive (and oil!) it had 150K on the clock and was running like a watch, no warning - bang. Oil checked the day before. Still started and drove to the mechanic's 5miles away!
Reply
#2
Dam.


Sent from my iPhone using Tapatalk
I DO MISS MY BERLINGO Heart
Reply
#3
Hope it turns out not too expensive
Reply
#4
Thanks for the replies, we've had a replacement engine fitted, new cambelt and waterpump etc. ran rough at first but reset timing now OK. fingers crossed.
Pappy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
REAR AXCEL
Last Post: ajcommercial
Today 09:36 PM
» Replies: 3
» Views: 68
Odd Issues with Rear Door Sensor
Last Post: dumdum
Today 09:25 PM
» Replies: 1
» Views: 50
display fading (MFD B, not bulb related)
Last Post: sks01773
Today 07:50 PM
» Replies: 42
» Views: 6120
Are Mud Flaps the Answer ?
Last Post: iscom
Today 07:10 PM
» Replies: 4
» Views: 176
Head Light Bulbs
Last Post: dargoion
Today 05:52 PM
» Replies: 33
» Views: 1001
radio code
Last Post: Tomcat3
Today 02:32 PM
» Replies: 3
» Views: 85
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Trevor
Today 02:13 PM
» Replies: 2
» Views: 50
Removing the rear roof storage bin (mk3 modutop)
Last Post: iscom
Today 01:31 PM
» Replies: 15
» Views: 6746
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 12:13 PM
» Replies: 4
» Views: 251
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 12:07 PM
» Replies: 1
» Views: 66

[-]
Recent Visitors
Locations of visitors to this page