Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine resurrection issues
#1
Hi Folks,

I've just replaced the engine in my 2001/2002  Berlingo 2.0hdi dw10. 
Its not starting! 
I'm not too good at diagnosing issues unfortunately.


The engine is turning over.
The glowplug light isnt coming on.
The fuel pump on both engines is the same.
Does my ecu speak to the new injectors/rail?
do i need to re-initialise the ecu.
does the new fuel pump work
have i connected the loom correctly.  
Ive checked the earths.

Any tips would be gratefully received.

Thanks Smile
Reply
#2
Is the equipment the same on new engine (ie injectors)
[-] The following 1 user says Thank You to Col for this post:
  • tortoise365
Reply
#3
You have to change BSI from donor car to yours also.

You probably have immobilizator issue.

It would be a lot easier if you have some diagnostic equipment.

Best regards,
brajomobil
[-] The following 1 user says Thank You to brajomobil for this post:
  • tortoise365
Reply
#4
Hi Thanks for the info,

I dont have the donor bsi! I have ordered diagnostic equipment!

I'll let you know how i get on,

Thanks,
Reply
#5
(05-05-2016, 09:52 AM)tortoise365 Wrote:  Hi Thanks for the info,

I dont have the donor bsi!  I have ordered diagnostic equipment!

I'll let you know how i get on,

Thanks,

Then you can do IMMO off on that engine ECU or install original BSI to
match original ECU. Without that engine will not start.

Best regards,
brajomobil
[-] The following 1 user says Thank You to brajomobil for this post:
  • tortoise365
Reply
#6
(04-05-2016, 12:56 PM)Col Wrote:  Is the equipment the same on new engine (ie injectors)

Good Point! 
 the Old engine has siemens injectors, rail and pump,

The new engine has siemens injectors, bosch rail and the pump has no sticker but looks the same as the old one.

I just want to avoid having to take the injection system apart. cos the haynes says you've got to buy new pipes if you do this. and keep everything clean! 

Thanks again!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Help needed have immobiliser fault and fan probl...
Last Post: Dennyboy
Today 01:02 PM
» Replies: 0
» Views: 4
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Andre
Today 11:23 AM
» Replies: 2
» Views: 197
Lucas mechanic fuel pump - disassembly and timin...
Last Post: yanivh
Today 11:01 AM
» Replies: 0
» Views: 25
Head Light Bulbs
Last Post: Tree
Today 08:38 AM
» Replies: 32
» Views: 898
EGR solenoid
Last Post: silver-slug
Today 08:31 AM
» Replies: 19
» Views: 1426
ABS Modul
Last Post: brajomobil
Today 08:07 AM
» Replies: 2
» Views: 105
Speedo/milometer fault
Last Post: Gixxerguyk8
Today 12:28 AM
» Replies: 15
» Views: 1456
Which wheel nuts?
Last Post: Stu999
Yesterday 11:50 PM
» Replies: 0
» Views: 53
VAN SECURITY
Last Post: ricc
Yesterday 08:29 PM
» Replies: 5
» Views: 176
Clanking Brake Pedal Solved At Last!
Last Post: rickandbev16
Yesterday 06:53 PM
» Replies: 17
» Views: 3446

[-]
Recent Visitors
Locations of visitors to this page