Thread Rating:
  • 5 Vote(s) - 3.2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] shuddering at low speeds
#1
Hello im new to this site and im looking for help, ive just bought a berlingo van 2005 1.9 enterprise, 60k miles.After a good run it starts to judder at low speeds, and at lights sounds like its going to stall. Also the stop warning light is flashing and the hand brake light stays on too, I have checked all fluid and brake pads they seem ok, has anyone and insight please, as im not great with engines. Thanks Barry
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Odd Issues with Rear Door Sensor
Last Post: GerardKeating
Today 12:27 AM
» Replies: 0
» Views: 3
Gearbox Fluid
Last Post: AlanS
Today 12:18 AM
» Replies: 14
» Views: 331
REAR AXCEL
Last Post: ajcommercial
Yesterday 11:57 PM
» Replies: 0
» Views: 6
Fuel Guage wrong
Last Post: ajcommercial
Yesterday 11:46 PM
» Replies: 2
» Views: 94
Longitudinal Roof rails on 2010 model
Last Post: Chrisville
Yesterday 08:42 PM
» Replies: 0
» Views: 26
radio code
Last Post: Tomcat3
Yesterday 07:14 PM
» Replies: 1
» Views: 39
Donation
Last Post: terryd999
Yesterday 06:15 PM
» Replies: 2
» Views: 39
Beeping with no error lights!!!
Last Post: sjparky
Yesterday 05:34 PM
» Replies: 11
» Views: 3760
Good Evening to you all.
Last Post: ron
Yesterday 04:33 PM
» Replies: 7
» Views: 208
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Yesterday 01:30 PM
» Replies: 3
» Views: 207

[-]
Recent Visitors
Locations of visitors to this page