Thread Rating:
  • 7 Vote(s) - 3.14 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fuel Filter
#1
Hello. Had my first problem today on 2011 Berlingo 1.6 hdi.
Been parked up for 3 days, in cold weather. fitted new snow tyres today and started no problem but after a couple of miles the engine warning light came on and it cut out.
Started up again and done the same after 50 yards or so.
Kept doing this so left it for 15 mins and started it again, this time I got a abot a mile before it stopped again.

Phoned Citeron and they told me a story about bad fuel from certain garages and that I should change filter and add additevs.

Started it up again after about half an hour and engine warning light had gone off and car works fine now, shop did not have the right filter so just put some Forte additeves in anyway.

Anyone have Any idea of the reason for this?? and do you think I should change the filter as it just had new one week before christmas??
Reply
#2
Open the drain and see what comes out.
[-] The following 1 user says Thank You to corkgsxr for this post:
  • ron
Reply
#3
(22-01-2013, 10:13 PM)kevinp Wrote:  Hello. Had my first problem today on 2011 Berlingo 1.6 hdi.
Been parked up for 3 days, in cold weather. fitted new snow tyres today and started no problem but after a couple of miles the engine warning light came on and it cut out.
Started up again and done the same after 50 yards or so.
Kept doing this so left it for 15 mins and started it again, this time I got a abot a mile before it stopped again.

Phoned Citeron and they told me a story about bad fuel from certain garages and that I should change filter and add additevs.

Started it up again after about half an hour and engine warning light had gone off and car works fine now, shop did not have the right filter so just put some Forte additeves in anyway.

Anyone have Any idea of the reason for this?? and do you think I should change the filter as it just had new one week before christmas??
Words fail me! What sort of garage would give such advice! There is obviously a problem that would be recorded in the ECU.
My advice would be to check with a proper garage.
Reply
#4
Phoned Citeron and they told me a story about bad fuel from certain garages and that I should change filter and add additevs.

It was one of those chinese fake brands-very subtle
Reply
#5
(22-01-2013, 11:27 PM)andylobb Wrote:  
(22-01-2013, 10:13 PM)kevinp Wrote:  Hello. Had my first problem today on 2011 Berlingo 1.6 hdi.
Been parked up for 3 days, in cold weather. fitted new snow tyres today and started no problem but after a couple of miles the engine warning light came on and it cut out.
Started up again and done the same after 50 yards or so.
Kept doing this so left it for 15 mins and started it again, this time I got a abot a mile before it stopped again.

Phoned Citeron and they told me a story about bad fuel from certain garages and that I should change filter and add additevs.

Started it up again after about half an hour and engine warning light had gone off and car works fine now, shop did not have the right filter so just put some Forte additeves in anyway.

Anyone have Any idea of the reason for this?? and do you think I should change the filter as it just had new one week before christmas??
Words fail me! What sort of garage would give such advice! There is obviously a problem that would be recorded in the ECU.
My advice would be to check with a proper garage.

It was my main Citeron Dealer.
Reply
#6
Engine fault light came on this morning for abot an hour then went off, cars been running fine all day.
Goint to change filter tomorrow.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Fuel Guage wrong
Last Post: Solent
Today 07:36 AM
» Replies: 4
» Views: 106
REAR AXCEL
Last Post: polar
Today 06:12 AM
» Replies: 1
» Views: 22
Odd Issues with Rear Door Sensor
Last Post: GerardKeating
Today 12:27 AM
» Replies: 0
» Views: 16
Gearbox Fluid
Last Post: AlanS
Today 12:18 AM
» Replies: 14
» Views: 347
Longitudinal Roof rails on 2010 model
Last Post: Chrisville
Yesterday 08:42 PM
» Replies: 0
» Views: 36
radio code
Last Post: Tomcat3
Yesterday 07:14 PM
» Replies: 1
» Views: 45
Donation
Last Post: terryd999
Yesterday 06:15 PM
» Replies: 2
» Views: 48
Beeping with no error lights!!!
Last Post: sjparky
Yesterday 05:34 PM
» Replies: 11
» Views: 3770
Good Evening to you all.
Last Post: ron
Yesterday 04:33 PM
» Replies: 7
» Views: 214
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Yesterday 01:30 PM
» Replies: 3
» Views: 217

[-]
Recent Visitors
Locations of visitors to this page