Thread Rating:
  • 11 Vote(s) - 2.55 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gremlins in the BSI?
#1
Hi, my 1.4l 2000 52 reg multi has been odd lately..

Similar to other threads here, the displays don't work except backlight with sidelights on, and engine starts fine. I found sometimes if i pull the handbrake the digital display and everything except rev counter come on. Indicators work but the click sound and display doesn't show it.

Strangely though if i drive for 5-10 mins then leave ignition off for 3-4 mins all displays decide to work!?

This has been happening for a couple of weeks, (don't use it much) and internal door lights worked as normal, but now the symbol for an open door is displayed and the internal lights stopped working on auto, when i indicate right the door light flashes with a beep.. not when i indicate left though!?

^^ that could be a seperate problem though as it's more recent?

I havn't tried a BSI reset yet, and wonder if anyone has thoughts, earth fault, loose fuses, low batterey or dodgy BSI? I'll go out tommorow and try a reset and check battery voltage then report back.

thanks al
[-] The following 1 user says Thank You to al barge for this post:
  • taxi
Reply
#2
Just a thought..

If the door open light is staying on, is it safe to do a BSI reboot, as it will think a door is open?

al
Reply
#3
Yes it's safe. The BSI controls all 'Body systems' so a re-set will
take the system back its default settings, which is
what you want.
The Older I get the Better I Was!  Cool
[-] The following 1 user says Thank You to Ol'Jeffers for this post:
  • al barge
Reply
#4
(29-12-2012, 01:20 PM)OlJeffers Wrote:  Yes it's safe. The BSI controls all 'Body systems' so a re-set will
take the system back its default settings, which is
what you want.

Thanks, i'll go and give it a try.
Reply
#5
Well i tried a BSI reboot, and it's acting exactly the same, battery is charging and holding a decent voltage, but it still thinks a door is open and randomly turns on the digital display and everything except rev counter occasionaly when turning on lights or pulling handbrake back on, but not always?

Is there anyone in east london with a lexia, need to check my local garage to see if they have diagnostics.

any other thoughts?

cheers
Reply
#6
If it is telling you that the same door is open every time
you could try checking that particular door latch mechanism may be
the switch is u/s or a wire is adrift.
The Older I get the Better I Was!  Cool
Reply
#7
(29-12-2012, 03:18 PM)OlJeffers Wrote:  If it is telling you that the same door is open every time
you could try checking that particular door latch mechanism may be
the switch is u/s or a wire is adrift.

Cheers OJ
Just checked, and both front and rear internal door lights stay on all the time, it doesn't seem to matter if any or all doors are closed and lights on auto.. Also indicating right makes the door open symbol flash with two beeps then it beeps in threes.. (maybe that means something to someone?)

I can't remember but does the digital display normally go off with a relay click after a minute or two of keys out of the ignition?

During all the tests and reboots either the engine being warm or battery topped up means all the displays start to work after every time ignition is turned, just how i'd found after a short drive before, but the door open warning light stays weird. (assume it's the door open symbol, not in the user manual though)
Reply
#8
Despite me being a retired electronics engineer at this point I
would be having a ring around to find an independent local motor
engineer with Lexia. If he's got Lexia then there's a fair chance that
he will know how to use it and be proficient at repairing Citroen/Pug.cars.
I'm lucky here in mid-Kent as I have three excellent independent repairers
all within a few miles. This really sounds like an intermittent connection
(a corroded multi-plug or similar) to me so your need to get all the fault
codes and eliminate them one by one.
The Older I get the Better I Was!  Cool
Reply
#9
(29-12-2012, 08:47 PM)OlJeffers Wrote:  Despite me being a retired electronics engineer at this point I
would be having a ring around to find an independent local motor
engineer with Lexia. If he's got Lexia then there's a fair chance that
he will know how to use it and be proficient at repairing Citroen/Pug.cars.
I'm lucky here in mid-Kent as I have three excellent independent repairers
all within a few miles. This really sounds like an intermittent connection
(a corroded multi-plug or similar) to me so your need to get all the fault
codes and eliminate them one by one.

Yeah i'm guessing this now, first i'll get my can of contact cleaner and 1200 grit out, then if there are any members in London with lexia willing to help please let me know! Otherwise I'll call around and see what luck i have with local garages over the next few days.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Odd Issues with Rear Door Sensor
Last Post: GerardKeating
Today 12:27 AM
» Replies: 0
» Views: 5
Gearbox Fluid
Last Post: AlanS
Today 12:18 AM
» Replies: 14
» Views: 335
REAR AXCEL
Last Post: ajcommercial
Yesterday 11:57 PM
» Replies: 0
» Views: 11
Fuel Guage wrong
Last Post: ajcommercial
Yesterday 11:46 PM
» Replies: 2
» Views: 95
Longitudinal Roof rails on 2010 model
Last Post: Chrisville
Yesterday 08:42 PM
» Replies: 0
» Views: 27
radio code
Last Post: Tomcat3
Yesterday 07:14 PM
» Replies: 1
» Views: 42
Donation
Last Post: terryd999
Yesterday 06:15 PM
» Replies: 2
» Views: 41
Beeping with no error lights!!!
Last Post: sjparky
Yesterday 05:34 PM
» Replies: 11
» Views: 3761
Good Evening to you all.
Last Post: ron
Yesterday 04:33 PM
» Replies: 7
» Views: 211
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Yesterday 01:30 PM
» Replies: 3
» Views: 212

[-]
Recent Visitors
Locations of visitors to this page