Thread Rating:
  • 6 Vote(s) - 2.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hi new owner needs help.
#1
Hi ya, just purchased a berlingo 2.0 hdi van on a y plate. When I got it drove it home fine without any issues, today took it to work put £20 worth of fuel in just over quarter on gauge drove few miles gauge drops loads. Got to work ok didn't think to much about it till went out again and pulling onto motorway building revs up engine management light comes on and shuts down engine.

Restarts fine drives ok till get to around 3000 rpm then does same. Went to mates garage fault codes p1517 and p1112 he told me they were coded anti start operation and fuel rail pressure?

Any one with any info on problem and fix would be great

Thanks ben
Reply
#2
Any ideas or solutions?

Thanks
Reply
#3
P1517 CODED ANTI-START OPERATION
P1112 FUEL RAIL PRESSURE

The first code I believe is the ECU's response to the second code in not allowing the engine to start.
The second code could indicate anything in the fuel line from a blocked or worn out injector to a failing
fuel or injector pump.
I'm no expert but I would take the car to a competent independent garage for a full check
and measurement of the fuel rail pressure plus an injector check.
Maybe one of our experts will be along later to give you more detailed/accurate advice.

Oh! Welcome to 'our' place!
The Older I get the Better I Was!  Cool
Reply
#4
Many thanks for the reply,

I wasn't sure if there was a common fault with them that someone may know. I have booked it for a full service so will see if fuel filter helps first if not will get get checked whilst at garage.

Any other ideas etc would be great.

Thanks again ben
Reply
#5
No problem, Ben. What mileage does the van have?
The Older I get the Better I Was!  Cool
Reply
#6
A lot lol traveled to moon and back few times.

216k.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Today 01:30 PM
» Replies: 3
» Views: 176
Help needed have immobiliser fault and fan probl...
Last Post: Dennyboy
Today 01:02 PM
» Replies: 0
» Views: 21
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Andre
Today 11:23 AM
» Replies: 2
» Views: 203
Lucas mechanic fuel pump - disassembly and timin...
Last Post: yanivh
Today 11:01 AM
» Replies: 0
» Views: 29
Head Light Bulbs
Last Post: Tree
Today 08:38 AM
» Replies: 32
» Views: 903
EGR solenoid
Last Post: silver-slug
Today 08:31 AM
» Replies: 19
» Views: 1427
ABS Modul
Last Post: brajomobil
Today 08:07 AM
» Replies: 2
» Views: 114
Speedo/milometer fault
Last Post: Gixxerguyk8
Today 12:28 AM
» Replies: 15
» Views: 1460
Which wheel nuts?
Last Post: Stu999
Yesterday 11:50 PM
» Replies: 0
» Views: 57
VAN SECURITY
Last Post: ricc
Yesterday 08:29 PM
» Replies: 5
» Views: 178

[-]
Recent Visitors
Locations of visitors to this page