Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Horn issue
#1
Hi. I have a issue with the horn on my berlingo. With the ignition off the horn works fine. As soon as I turn the ignition on or start the van. Horn stops working. Not getting any voltage to the horn. But with ignition off a good 12.4 volts. Earth is fine, have checked this by using the earth on the horn connector to the battery positive and get 12v again.

Any help?

Cheers Big Grin
Reply
#2
Hi there it is more than likely the earth connection under the airbag on the steering wheel. I had the same problem and there are loads of threads on here about it. Its a crap design its just a piggyback spade type connector pushed into a square hole. after a few years and a bit of wear it don't fit to tight. Some have just wrapped wire round the steering column to sort it but I took the airbag off cut the connector off attached a ring connector, then drill a small hole in the wheel and screwed it to that. Jobs a good one.
Have a read of this http://www.berlingoforum.co.uk/thread-3633-page-2.html
Hope this helps.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#3
Thank you for the reply. Will try that tomorrow.
Reply
#4
I fixed this on mine a few days ago, it was exactly what Tomcat3 said. Except I didn't have a loop so I have banged a block of metal into it to wedge it in. I also sanded all the contacts just in case.

I hear the airbag can be dodgy and people have recommended removing the battery for around half an hour before trying to take it off.

There is another thread about it here, some nice pictures on the second page:

http://www.berlingoforum.co.uk/showthread.php?tid=3633
2005 Enterprise 600 1.9D - It did 85 once but started to smell funny.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Tyre Change...old on front new on back
Last Post: RocketVANman
Today 11:32 PM
» Replies: 5
» Views: 56
Finally a B9 Haynes Manual
Last Post: Satellitemark
Today 08:26 PM
» Replies: 33
» Views: 2210
Fuel rail pipe replacement
Last Post: Peter Palmer
Today 08:19 PM
» Replies: 2
» Views: 42
REAR AXCEL
Last Post: Tomcat3
Today 07:31 PM
» Replies: 5
» Views: 130
Berlingo B9 2008 Just Testing The Water
Last Post: nickyboy4
Today 06:34 PM
» Replies: 0
» Views: 29
Starting issues
Last Post: technique1966
Today 06:00 PM
» Replies: 0
» Views: 27
Insurance cost
Last Post: jonny705
Today 05:33 PM
» Replies: 0
» Views: 33
Newbie
Last Post: j.ted
Today 04:40 PM
» Replies: 2
» Views: 43
Are Mud Flaps the Answer ?
Last Post: Top drive
Today 04:02 PM
» Replies: 11
» Views: 314
Is anyone buying a new car AFTER April 2017?
Last Post: Solent
Today 03:35 PM
» Replies: 1
» Views: 51

[-]
Recent Visitors
Locations of visitors to this page