Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to get at the blower
#1
Chaps

2010 1.6 HDI.....4 stage blower only works on 4. I assume replace the transistors near the motor....

However, where is the blower! Looked above passenger well....cannot see it!

Any clues as to its location and how to get at the blower motor to replace the transistors much appreciated.

Cheers

Mark
Reply
#2
The blower is behind the radio hard to get to the transistor / resister on the B 9 is in the glove box behind the fuse's if you take the fuse cove off and remove the fixing's holding the fuse's move the a bit you will see a small bright green box look's like a relay i think that's the resister that need's replacing some one on here did a thread on it .
Some put me right if i'm wrong . Sad
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#3
Hi it's me again Smile if you go to page 8 on the B9 post you will see a thread on Blower not working it will show you how to fit a new resister behind the fuse's in the glove box with pics and the the blower is on the driver's side under the dash .
Can the mods put this in the how to so it's is easy to find. Wink
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#4
Here you go http://www.berlingoforum.co.uk/thread-12400.html
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
[-] The following 1 user says Thank You to Tomcat3 for this post:
  • Jed Clampit
Reply
#5
Thanks Tomcat wish i could do that one day i'll work it out. Rolleyes
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#6
Hmmm...are you sure the green box you mention is the resistor for the motor? From what I read, the resistor is on the motor somewhere.......
Reply
#7
The resistor pack is normally somewhere with good airflow, to keep it cool. They're usually in the blower outlet, with a metal heatsink stuck into the moving air.

I think we're talking about the relay. I'm guessing that this is what selects between the different fan speeds. Relays do suffer from arcing, especially when switching high currents.
Reply
#8
(18-02-2016, 07:58 AM)doofer Wrote:  The resistor pack is normally somewhere with good airflow, to keep it cool.  They're usually in the blower outlet, with a metal heatsink stuck into the moving air.

I think we're talking about the relay.  I'm guessing that this is what selects between the different fan speeds.  Relays do suffer from arcing, especially when switching high currents.

Agreed to the former, and from what I understand, if the blower works on setting 4 - which it does - then it is this resistor pack which is at fault.

The green thing discussed in previous posts is, I think, some sort of fuse and replacement of this component will not help matters.
Reply
#9
The transistors in the blower motor are not similar to the green relay/fuse replaced above. You can see the transistors and where they sit for a xsara blower in this video

https://www.youtube.com/watch?v=8X5Y-66cYSA

Of course depending on your model they can sit in different places in the motor, but as long as they are PSA made, the transistors will look similar. I know that for a pug306 they stayed in the back of the motor lid, it was easy access and easy fix. In the case of the Berlingo I don´t have a clue, but I bet It won´t differ much from the xsara...

In this example the sit inside the assembly...

Edit: the example is for a xsara not a xsara picasso, but the transistors look the same... carefull when buying the new parts as the transistor´s part numbers have to be exactly the same, don´t go swithching PNP for NPN transistors...
Reply
#10
Another common problem and fix instructions with the full auto dual zone A/C systems that were installed in older PSA cars (I have also crossed with this problem in my 307sw pug, I did a 2700km trip with my side stuck on hot Sad )

https://www.youtube.com/watch?v=v9eNGTPABI4

Please enable the english subtitles.

Cheers.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Is anyone buying a new car AFTER April 2017?
Last Post: doofer
Today 03:02 PM
» Replies: 0
» Views: 5
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 02:55 PM
» Replies: 6
» Views: 280
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: rickandbev16
Today 02:12 PM
» Replies: 4
» Views: 88
Finally a B9 Haynes Manual
Last Post: rickandbev16
Today 02:04 PM
» Replies: 32
» Views: 2137
Are Mud Flaps the Answer ?
Last Post: doofer
Today 12:41 PM
» Replies: 10
» Views: 270
Head Light Bulbs
Last Post: doofer
Today 09:38 AM
» Replies: 35
» Views: 1063
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Bob Southey
Today 07:43 AM
» Replies: 3
» Views: 278
REAR AXCEL
Last Post: ajcommercial
Yesterday 09:36 PM
» Replies: 3
» Views: 101
Odd Issues with Rear Door Sensor
Last Post: dumdum
Yesterday 09:25 PM
» Replies: 1
» Views: 79
display fading (MFD B, not bulb related)
Last Post: sks01773
Yesterday 07:50 PM
» Replies: 42
» Views: 6167

[-]
Recent Visitors
Locations of visitors to this page