Thread Rating:
  • 1 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Intermittent speedo
#1
Hi, iam new to the forum, I have a 57 plate berlingo van and for the last year it's had a fault with the speedo, just randomly stops working, maybe for a minute or sometimes longer? There is no reason it does it, can be straight away when it's cold , hot? My first thought is a speed sensor. So I managed to get one, went to change it the other day and can I find it, I looked everywhere. Any ideas as to the location and if iam looking at the right thing??


Thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
BULBS!!
Last Post: Hughzie
Today 09:43 PM
» Replies: 14
» Views: 522
Head Light Bulbs
Last Post: Hughzie
Today 09:23 PM
» Replies: 36
» Views: 1118
Finally a B9 Haynes Manual
Last Post: Hughzie
Today 08:53 PM
» Replies: 38
» Views: 2452
Newbie
Last Post: Jed Clampit
Today 08:37 PM
» Replies: 6
» Views: 84
first time ctroen owner
Last Post: Jed Clampit
Today 08:25 PM
» Replies: 1
» Views: 28
TRAILER WANTED
Last Post: Tomcat3
Today 07:15 PM
» Replies: 3
» Views: 64
M59 Cooling system change PDF
Last Post: coatess
Today 06:46 PM
» Replies: 1
» Views: 206
What to look for when buying?
Last Post: polar
Today 06:16 PM
» Replies: 6
» Views: 73
clunking noise
Last Post: polar
Today 06:13 PM
» Replies: 3
» Views: 50
Next gen berlingo multispace
Last Post: doofer
Today 05:55 PM
» Replies: 9
» Views: 172

[-]
Recent Visitors
Locations of visitors to this page