Thread Rating:
  • 32 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Loss of power
#1
Engine loosing power and a vibration Berlingo going into dealer tomorrow, maybe an injector?!
Car has done 17k.
I DO MISS MY BERLINGO Heart
Reply
#2
Did you see any fuel leakages under bonnet?
Reply
#3
Hi PK, no havnt seen any.
I DO MISS MY BERLINGO Heart
Reply
#4
Ok got car back from dealer and they could not find a problem with a road test or on the machine, they did say maybe it has to develop into a bigger problem or until a warning light comes on.
I DO MISS MY BERLINGO Heart
Reply
#5
(16-09-2011, 09:03 AM)philip Wrote:  Ok got car back from dealer and they could not find a problem with a road test or on the machine, they did say maybe it has to develop into a bigger problem or until a warning light comes on.
How's the car now ?- I hope the blingo's loss of power problems disappeared
Former 2011 Mk3 XTR owner Confusedalut:
Reply
#6
Nope still loosing power from time to time.


Sent from my iPhone using Tapatalk
I DO MISS MY BERLINGO Heart
Reply
#7
Hi Philip.
Try to change petrol station.
Reply
#8
DAft reply, TBH but when you are moving, and its safe to try this, press the footbrake slightly together with the Accel pedal, and see if you loose power, I believe that when you press the foot brake it slightly kills power to the engine, had this problem on an 53 plate Xara Pic exclusive (cruise control fitted) there was 2x micro switches on the pedal on that model., just for your info as that was my problem a few years back..
Reply
#9
(18-11-2011, 09:06 PM)pk7478 Wrote:  Hi Philip.
Try to change petrol station.
Hmmm never thought of that one, i do normally use either Esso or Morrisons.


(18-11-2011, 10:27 PM)digger Wrote:  DAft reply, TBH but when you are moving, and its safe to try this, press the footbrake slightly together with the Accel pedal, and see if you loose power, I believe that when you press the foot brake it slightly kills power to the engine, had this problem on an 53 plate Xara Pic exclusive (cruise control fitted) there was 2x micro switches on the pedal on that model., just for your info as that was my problem a few years back..
Im not going to know if it looses power because of the micro switches or because i have braked Confusedcratch:

I DO MISS MY BERLINGO Heart
Reply
#10
(19-11-2011, 07:20 AM)philip Wrote:  
(18-11-2011, 09:06 PM)pk7478 Wrote:  Hi Philip.
Try to change petrol station.
Hmmm never thought of that one, i do normally use either Esso or Morrisons.

In fact it's a good idea. Several years ago when I used a petrol from BP, i was tire to replace spark plugs every 3000-4000 km. After changing a petrol station everything become ok.

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
BULBS!!
Last Post: Hughzie
Today 09:43 PM
» Replies: 14
» Views: 519
Head Light Bulbs
Last Post: Hughzie
Today 09:23 PM
» Replies: 36
» Views: 1118
Finally a B9 Haynes Manual
Last Post: Hughzie
Today 08:53 PM
» Replies: 38
» Views: 2452
Newbie
Last Post: Jed Clampit
Today 08:37 PM
» Replies: 6
» Views: 83
first time ctroen owner
Last Post: Jed Clampit
Today 08:25 PM
» Replies: 1
» Views: 27
TRAILER WANTED
Last Post: Tomcat3
Today 07:15 PM
» Replies: 3
» Views: 63
M59 Cooling system change PDF
Last Post: coatess
Today 06:46 PM
» Replies: 1
» Views: 206
What to look for when buying?
Last Post: polar
Today 06:16 PM
» Replies: 6
» Views: 73
clunking noise
Last Post: polar
Today 06:13 PM
» Replies: 3
» Views: 50
Next gen berlingo multispace
Last Post: doofer
Today 05:55 PM
» Replies: 9
» Views: 172

[-]
Recent Visitors
Locations of visitors to this page