Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
More ABS trouble
#1
I've got an ABS warning lamp up again on my 2009 1.6 diesel B9 Berlingo. This time I can't detect any voltage on the sensors (previously had 11.5 - 13v on supply lead to sensor). Nor have I detected any voltage in supply to the ABS unit. Can anyone direct me to the correct fuse (I've checked them all OK in the engine compartment fuse box). Also - I think there is a relay involved, at front left side of engine compartment, on the front of the fuse box assembly. Is this the correct relay?

Thanks.
Reply
#2
(23-05-2015, 06:39 PM)Boxer Wrote:  I've got an ABS warning lamp up again on my 2009 1.6 diesel B9 Berlingo. This time I can't detect any voltage on the sensors (previously had 11.5 - 13v on supply lead to sensor). Nor have I detected any voltage in supply to the ABS unit. Can anyone direct me to the correct fuse (I've checked them all OK in the engine compartment fuse box). Also - I think there is a relay involved, at front left side of engine compartment, on the front of the fuse box assembly. Is this the correct relay?

Thanks.

There are 2 relays R6 and R7 . Check all the fuses in the schematic named F1 .... F13.

Note: This is general B9 abs schematic. If it is not helpful You can send me in P.M. VIN and OPR so I can send you correct one...

Best regards,
brajo

.pdf   berlingo_b9_abs_shematic.pdf (Size: 314.13 KB / Downloads: 31)
[-] The following 1 user says Thank You to brajomobil for this post:
  • Boxer
Reply
#3
yes that is the abs relay on the front outside of fuse box, mine was faulty, about £45 from the dealer
[Image: 2dedca76-4da1-4bd2-aea1-452ddda68256.jpg]
[-] The following 2 users say Thank You to finny for this post:
  • Boxer, brajomobil
Reply
#4
Thanks, brajo
I'll have a look through this and recheck my fuses - I have checked the ones in the engine compartment and the big fuses underneath the top fuses, but no problem doing them again. The relay that I have checked so far is on the front of the main fuse box. I found 12v on several connections into that relay (measured at the socket the relay is plugged into), but no sign of 12v arriving at the main ABS unit to which the relay output seems to be connected. I have ordered a relay (may be a mistake now that I know there are two of them). Do you know where the other is?

I'll pm you details when I get them from my daughter who normally uses the car. She lets me have it back when it is broken!

Thanks again brajo.
Reply
#5
Thanks finny,
It's on order. 
Reply
#6
the one on the front is defo the abs relay, my mate is was the electronics man at the local Peugeot dealer, my fault was intermittent, abs light on, used to reset it by turning van off and back on
[Image: 2dedca76-4da1-4bd2-aea1-452ddda68256.jpg]
Reply
#7
(25-05-2015, 08:51 AM)Boxer Wrote:  Thanks, brajo
I'll have a look through this and recheck my fuses - I have checked the ones in the engine compartment and the big fuses underneath the top fuses, but no problem doing them again. The relay that I have checked so far is on the front of the main fuse box. I found 12v on several connections into that relay (measured at the socket the relay is plugged into), but no sign of 12v arriving at the main ABS unit to which the relay output seems to be connected. I have ordered a relay (may be a mistake now that I know there are two of them). Do you know where the other is?

I'll pm you details when I get them from my daughter who normally uses the car. She lets me have it back when it is broken!

Thanks again brajo.

The other one is mounted on BSI , Fuse : F13 , you have to pull out BSI, first remove all wire connectors, then pull out BSI.
When you look at the base of the wire connector you see small numbers printed that numbers correspond to numbers on the schematic.
Check if 12v is coming to F13
Reply
#8
This link. while not for the Berlingo itself may be of use to people like me who aren't familiar with Citroen/Peugeot wiring diagrams and associated symbols, numbering etc.



http://www.autoelectric.ru/auto/peugeot/...rams.htm#1
[-] The following 2 users say Thank You to Boxer for this post:
  • brajomobil, ddb
Reply
#9
Well, car is sorted again. I eventually confirmed I was getting power to the ABS controller (a big thank you to brajomobil for the wiring diagram) but that I was not getting 12v at the front wheel sensors, which I did last time. I put the car onto a fault reader and found that the two rear brakes were working well, but there was no signal from the front two. This tied in with there being no voltage at the front sensors.
Just about then I got the name of an independent auto electrician who has a good reputation, often called in by dealers. He sorted it in a half day.
I had one faulty abs sensor on one side of the front and a bad connection on the other side. Like last time, basic circuit checking is still important despite all the technology. The electrician sorted out the faulty plug that I had by-passed last time.

If Im honest I would say that if I'd given him the car the first time this happened he would have sorted it much quicker than I did. It's also possible that in probing around with my multimeter I had deformed connections in the various plugs.

Let's see how long it works for this time.
Thanks again to everyone.
Reply
#10
(05-06-2015, 08:21 AM)Boxer Wrote:  Well, car is sorted again. 

Glad you sorted it out.

Best regards,
brajomobil
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
BULBS!!
Last Post: Jed Clampit
Yesterday 11:05 PM
» Replies: 17
» Views: 549
Finally a B9 Haynes Manual
Last Post: Satellitemark
Yesterday 10:43 PM
» Replies: 39
» Views: 2470
clunking noise
Last Post: Silverberlingo
Yesterday 10:35 PM
» Replies: 4
» Views: 60
TRAILER WANTED
Last Post: Silverberlingo
Yesterday 10:29 PM
» Replies: 4
» Views: 74
longitudinal roof rails
Last Post: Chrisville
Yesterday 10:27 PM
» Replies: 0
» Views: 17
Head Light Bulbs
Last Post: Hughzie
Yesterday 09:23 PM
» Replies: 36
» Views: 1131
Newbie
Last Post: Jed Clampit
Yesterday 08:37 PM
» Replies: 6
» Views: 86
first time ctroen owner
Last Post: Jed Clampit
Yesterday 08:25 PM
» Replies: 1
» Views: 34
M59 Cooling system change PDF
Last Post: coatess
Yesterday 06:46 PM
» Replies: 1
» Views: 209
What to look for when buying?
Last Post: polar
Yesterday 06:16 PM
» Replies: 6
» Views: 74

[-]
Recent Visitors
Locations of visitors to this page