Thread Rating:
  • 7 Vote(s) - 3.14 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Nozzle-problem window washer?
#1
Hello, new user with an old Berlingo!
I bought my yellow Berlingo without having physically seen or driven it, on an auction. Must say, Im actually quite happy with it!

However, one or two issues do bother me.
1: why is it that I spend an afternoon to yank out the faulty cigarette lighter socket, the one I bought turns out to have the wrong contact?

2: I can't seem to get any window washer fluid on to my windscreen. The headlights get a good washing, I think it even works in the back, but no fluid comes out of my nozzles (no pun intended..). Anyone with an idea as to what can cause this? Apparantly, the fuse is ok.

regards
'00 Berlingo Multispace 1.4 petrol with the big sunroof
Norway
Reply
#2
Hi and welcome to 'our' place!
Over time the washer fluid reservoir gets a lot of
sediment in the bottom. Again, over time, this tends to find it's way up the hoses and
it collects behind the nozzles in the jets.
If the pump is working then it will only require the hoses to be flushed through and
the nozzles renewed. Disconnect the hoses from the nozzles first and try the washers.
Water should come from the hoses at a healthy rate. If it doesn't then the pump may be worn out,
but don't worry as they're quite cheap and can be found on eBay for less than £10 (about 90NOK, I think)
Glad you otherwise like your 'new' car and look forward to seeing you here.
We have, I believe, two other Norwegian owners here too.
The Older I get the Better I Was!  Cool
[-] The following 1 user says Thank You to Ol'Jeffers for this post:
  • onepointfour
Reply
#3
(19-11-2012, 02:08 AM)OlJeffers Wrote:  Hi and welcome to 'our' place!
Over time the washer fluid reservoir gets a lot of
sediment in the bottom. Again, over time, this tends to find it's way up the hoses and it collects behind the nozzles in the jets. If the pump is working then it will only require the hoses to be flushed through and the nozzles renewed. Disconnect the hoses from the nozzles first and try the washers.
Water should come from the hoses at a healthy rate. If it doesn't then the pump may be worn out, but don't worry as they're quite cheap and can be found on eBay for less than £10 (about 90NOK, I think) Glad you otherwise like your 'new' car and look forward to seeing you here.
We have, I believe, two other Norwegian owners here too.

Thank you, I'll try! The nozzles themselves, they just clip off? I'll give the hoses a go later tonight, I can't be driving about dark, dirty and wet road with dirty windows, quite a hazard..
Reply
#4
(19-11-2012, 08:07 AM)onepointfour Wrote:  [quote='Ol'Jeffers' pid='30734' dateline='1353290891']
Hi and welcome to 'our' place!
Over time the washer fluid reservoir gets a lot of
sediment in the bottom. Again, over time, this tends to find it's way up the hoses and it collects behind the nozzles in the jets. If the pump is working then it will only require the hoses to be flushed through and the nozzles renewed. Disconnect the hoses from the nozzles first and try the washers.
Water should come from the hoses at a healthy rate. If it doesn't then the pump may be worn out, but don't worry as they're quite cheap and can be found on eBay for less than £10 (about 90NOK, I think) Glad you otherwise like your 'new' car and look forward to seeing you here.
We have, I believe, two other Norwegian owners here too.

The nozzles cleared up, almost by themselves. Shoved a piece of steel (sticks out of this little gadget http://www.bilxtra.no/hjem/bilutstyr/tun...ladrenser/) in the nozzles, and bob's your uncle - they started to spray my windscreen with lovely window-wash, result! Confusedunny:
Reply
#5
That's great! I still think you should at least flush the system through.
Nozzles disconnected and fill the reservoir with hot water and washing-up liquid
but make sure that this mixture goes into a bucket when you're pumping it through.
There's a lot of salt in washing up liquid which you don't need in your engine bay!
The Older I get the Better I Was!  Cool
[-] The following 1 user says Thank You to Ol'Jeffers for this post:
  • onepointfour
Reply
#6
(20-11-2012, 02:19 PM)OlJeffers Wrote:  That's great! I still think you should at least flush the system through.
Nozzles disconnected and fill the reservoir with hot water and washing-up liquid
but make sure that this mixture goes into a bucket when you're pumping it through.
There's a lot of salt in washing up liquid which you don't need in your engine bay!

Stupid Question of the Day: do I need to empty the reservoir first?
Reply
#7
The only 'stupid questions' are the ones you don't ask!

No! You can pump out the reservoir's contents and then re-fill with
hot detergent laden water then pump that through. I'd do it a couple of times.
If you have the inclination you could also remove the reservoir and thoroughly
clean it in the comparative comfort of the wife's kitchen sink!! Don't tell her though!!
The Older I get the Better I Was!  Cool
[-] The following 1 user says Thank You to Ol'Jeffers for this post:
  • onepointfour
Reply
#8
(21-11-2012, 06:48 PM)OlJeffers Wrote:  The only 'stupid questions' are the ones you don't ask!

No! You can pump out the reservoir's contents and then re-fill with
hot detergent laden water then pump that through. I'd do it a couple of times.
If you have the inclination you could also remove the reservoir and thoroughly
clean it in the comparative comfort of the wife's kitchen sink!! Don't tell her though!!

I wouldn't even dare dreaming of letting her know if I was planning to clean out the reservoir in her sink :whistle:

I'll give it a go, I have read in here somewhere though that running the washer with an empty reservoir tends to burn the pump, this sounds like a two-man job, one to hold the lever inside the car, and one to keep watch for the reservoir. And I had planned to do this with a bit of tape and in my own company..
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Next gen berlingo multispace
Last Post: churmy
Today 04:58 PM
» Replies: 7
» Views: 102
New Berlingo Auto Box - Anyone have one?
Last Post: Capelbond
Today 04:10 PM
» Replies: 9
» Views: 351
Newbie
Last Post: Onall4
Today 03:16 PM
» Replies: 0
» Views: 17
Finally a B9 Haynes Manual
Last Post: Satellitemark
Today 02:32 PM
» Replies: 37
» Views: 2394
glow plugs
Last Post: z1000pete
Today 10:21 AM
» Replies: 0
» Views: 27
Is anyone buying a new car AFTER April 2017?
Last Post: doofer
Today 09:10 AM
» Replies: 12
» Views: 227
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Hora
Today 07:04 AM
» Replies: 5
» Views: 157
Fuel rail pipe replacement
Last Post: polar
Today 06:54 AM
» Replies: 4
» Views: 102
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 48
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1572

[-]
Recent Visitors
Locations of visitors to this page