Thread Rating:
  • 6 Vote(s) - 2.17 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Possible BSI Solution
#1
Evening guys. I've got a 2003 1.9d van (facelift model) that has no clocks / instruments working. It runs fine and lights work however indicating makes the glow plug light flash. I've popped a set of clocks in with no joy. After inspection it appears that the connector from instruments into BSI has suffered slight damp which is causing the problem. Now, before I get it sent away for reman I had a thought and wanted to see what you guys think...

I can remove the old BSI and pop in a used one. If I were to bypass the immobiliser would a used BSI work??? I've tried bypassing immobiliser and running van without BSI and it runs fine so is there anything else that would prevent a used BSI working.

Any / all thoughts welcome.

Phill.
Reply
#2
No you should be fine running the van, but the configuration may need changing to suit your van, get it on peugeot planet and print the list of options off, then reprogram the new bsi with it, it's easy to break bits, we had a guy who did this and just plugged the bsi in, it was fine until he locked the van, bsi had deadlocking, his locks weren't and it killed the door latches... Be warned to get someone who knows what there doing Wink
Reply
#3
Thanks. TBH I cracked my bsi open Friday night just for a nose and it looked fine inside so have sent it away to rollingmotion for inspection / repair. I don't need the van for a few weeks anyway so thought I'd try that route first.

On a related subject I felt the carpet in the drivers footwell and although it felt dry to the touch when I lifted the carpet it was saturated. I got the wet and dry vac in and have removed aprox 3/4 bucket of water from the backing foam and it's still damp. Have took it out to air. After checking windscreen etc it would appear the culprit was leave and crap blocked the drivers side drain hole beneath the wipers. Couple that with the fact the vans been sat facing steeply uphill for about a month and I think we know where the damp connected came from in the first place.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
glow plugs
Last Post: z1000pete
Today 10:21 AM
» Replies: 0
» Views: 18
Next gen berlingo multispace
Last Post: churmy
Today 09:42 AM
» Replies: 4
» Views: 81
Is anyone buying a new car AFTER April 2017?
Last Post: doofer
Today 09:10 AM
» Replies: 12
» Views: 222
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Hora
Today 07:04 AM
» Replies: 5
» Views: 153
Fuel rail pipe replacement
Last Post: polar
Today 06:54 AM
» Replies: 4
» Views: 100
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 46
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1567
Another seat belt question
Last Post: berreke
Yesterday 09:02 PM
» Replies: 1
» Views: 51
hi all
Last Post: Jed Clampit
Yesterday 08:39 PM
» Replies: 2
» Views: 54
Tyre Change...old on front new on back
Last Post: RocketVANman
Yesterday 08:26 PM
» Replies: 12
» Views: 213

[-]
Recent Visitors
Locations of visitors to this page