Thread Rating:
  • 21 Vote(s) - 2.62 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Possible ECU problem
#1
My father in law's been advised by Citroen that his ECU needs replacing. This is due to the "stop" light constantly flashing on his dashboard. I'm assuming this is the engine management light. Confusedcratch: The temperatue guage is also constantly right up, although he has recently had a plug of some sort replaced due to constant overheating problems (the overheating has now stopped). I've had a look on the internet, as Citroen have obviously quoted a ridiculous price for the work :joker:, and there seems to be a couple of things I could try first. Does anyone know how to carry out a flash reset on the ECU? It seems there is a separate ECU for the engine and one for the dashboard and as the car is running just fine I'm assuming it's the dashboard ECU that's faulty and not the engine ECU. Can anyone help?
Does this even sound right?

Cheers,

Spaz
Reply
#2
   

Something to look at/research in the mean time. Can provide more if needed.
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply
#3
temperature up? stop light displayed?

Problem = engine temperature sender = http://cgi.ebay.co.uk/SAXO-BERLINGO-BOX-...875wt_1139

Had the same problem on mine, I took it out to get a part number, put it back and it's been fine for 3 years!
Somedays you're the pigeon, Somedays you're the statue.
Reply
#4
For BSI reset see below:

http://www.bba-reman.com/content.aspx?co...ot_process
How much is the fish?
Reply
#5
It seems like the old "Wiggle-Wiggle" test for bad connections is the first stage of fault analysis/diagnosis.

This methodology has worked twice now on the Berlingo....
First time was the connector to the seat belt pre-tensioner beneath the drivers seat.
Second time was actually done under a used-vehicle warranty issue, by the main dealer. After troubleshoot/diagnosis/scratching of heads, the connections to part of the EGR system were wiggled and started working again.

Clearly, Citroen seem to have an ongoing issue with connectors and wire terminations that are not water or dirt proof and appear to corrode easily.
Berlingo Multispace 2.0HDI '54 reg Mediterranean Blue
Reply
#6
Steve, this part seems to be the one that was replaced before the problems with the stop light started showing. Since being replaced the gauge shows max temp a few seconds after starting the engine and the stop light comes on. Knobblywobbly - I'm gonna try the BSI reset and see what happens, but I'll try the old 'Wiggle-Wiggle' test first. Has anyone on here reset the BSI in this way before? It seems the sort of thing that could screw something up at any stage if not done correctly........Since writing this reply I took another look and noticed it's for a Peugeot, I take it this doesn't make a difference?
Reply
#7
Could it be the dash clocks that's at fault? I'd try the wiggle test first, or try taking the sensor out and putting it back in.
Somedays you're the pigeon, Somedays you're the statue.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Newbie
Last Post: j.ted
Today 04:40 PM
» Replies: 2
» Views: 25
Are Mud Flaps the Answer ?
Last Post: Top drive
Today 04:02 PM
» Replies: 11
» Views: 283
Is anyone buying a new car AFTER April 2017?
Last Post: Solent
Today 03:35 PM
» Replies: 1
» Views: 25
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 02:55 PM
» Replies: 6
» Views: 283
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: rickandbev16
Today 02:12 PM
» Replies: 4
» Views: 95
Finally a B9 Haynes Manual
Last Post: rickandbev16
Today 02:04 PM
» Replies: 32
» Views: 2155
Head Light Bulbs
Last Post: doofer
Today 09:38 AM
» Replies: 35
» Views: 1069
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Bob Southey
Today 07:43 AM
» Replies: 3
» Views: 280
REAR AXCEL
Last Post: ajcommercial
Yesterday 09:36 PM
» Replies: 3
» Views: 105
Odd Issues with Rear Door Sensor
Last Post: dumdum
Yesterday 09:25 PM
» Replies: 1
» Views: 82

[-]
Recent Visitors
Locations of visitors to this page