Thread Rating:
  • 18 Vote(s) - 2.94 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Power Steering problems
#1
Hello all,
I have a 56 plate 2.0 hdi, and the power steering only works when driving.
When stopped but on tick over steering very hard.
I've had the van 18 month and only started to do this the last couple of days.
Fluid level is ok any ideas?

Cheers Jay
Reply
#2
(14-08-2012, 07:41 PM)Jr71 Wrote:  Hello all,
I have a 56 plate 2.0 hdi, and the power steering only works when driving.
When stopped but on tick over steering very hard.
I've had the van 18 month and only started to do this the last couple of days.
Fluid level is ok any ideas?

Cheers Jay

Try draining and refilling the system with a good fluid.Forte PAS fluid additive also works well.Try before condemning the system.Also check the belt is OK.
Strawberry flavoured windows  Dodgy
Reply
#3
Thanks,
I have looked at the belt seems tight enough.
Will try draining.
Cheers Jay
Reply
#4
Good luck
Strawberry flavoured windows  Dodgy
Reply
#5
I found if the belt's not tight enough it will scream at you.
Reply
#6
The belt doesn't wine or screech,
Cheers
Reply
#7
Are you sure your steering is working on the move? most vehicles lack of power steering is not noticed when once moving (old enough to remember when power steering was only fitted to Jags/ Citroen DS etc)
Reply
#8
Yes it is working when the revs go up. My first car was a vauxhall viva for £60, so I can remember cars with no power steering or brakes Smile
Reply
#9
I've drained and put fresh fluid in, but it's still the same. Can't understand why it works when you rev it up?
Reply
#10
Does seem a bit odd. Perhaps the power steering pump is on its way out. I don't suppose the belt could slip and not screech could it?
Malc

Stupid computer!
Security system should not fail safe!
Security system should fail dangerous!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Newbie
Last Post: j.ted
Today 04:40 PM
» Replies: 2
» Views: 24
Are Mud Flaps the Answer ?
Last Post: Top drive
Today 04:02 PM
» Replies: 11
» Views: 282
Is anyone buying a new car AFTER April 2017?
Last Post: Solent
Today 03:35 PM
» Replies: 1
» Views: 24
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 02:55 PM
» Replies: 6
» Views: 283
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: rickandbev16
Today 02:12 PM
» Replies: 4
» Views: 95
Finally a B9 Haynes Manual
Last Post: rickandbev16
Today 02:04 PM
» Replies: 32
» Views: 2155
Head Light Bulbs
Last Post: doofer
Today 09:38 AM
» Replies: 35
» Views: 1068
BerlingoForum.co.uk moving over to BerlingoForum...
Last Post: Bob Southey
Today 07:43 AM
» Replies: 3
» Views: 280
REAR AXCEL
Last Post: ajcommercial
Yesterday 09:36 PM
» Replies: 3
» Views: 105
Odd Issues with Rear Door Sensor
Last Post: dumdum
Yesterday 09:25 PM
» Replies: 1
» Views: 81

[-]
Recent Visitors
Locations of visitors to this page