Thread Rating:
  • 3 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Radiator Fans not working
#1
Wink 
Hi, I have a Berlingo 98 Van, 1.4 Lts. The car overheated once and unplugged the temperature sensors one by one located on the Thermostat box, 3 sensors in total. The fans worked when disconnecting the Sensor with the brown connector. I replaced it for a new one but the problem continued. The Air Con and fans work fine if I reconnect such sensor, but if I leave the Air Con off the fans won't start.

I identified the temperature sender for the temperature indication. Other sensor has a Green connector and is close to the brown one, but don't know what does it do

Any idea of what the problem is??

thanks for your help
Reply
#2
Hi,
Have a read through this thread
http://www.berlingoforum.co.uk/showthread.php?tid=3294
Had same problems as you.
HTH,
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#3
(30-12-2014, 05:38 PM)Landmark Wrote:  Hi,
Have a read through this thread
http://www.berlingoforum.co.uk/showthread.php?tid=3294
Had same problems as you.
HTH,
Griff
Reply
#4
The Air-con system is controlling the radiator fan, too.

Is it 'just overheating' or does it boil over?

If it boils over it probably wouldn't hurt to pressure test the system.
Don't forget to test the radiator cap(there's a 1.4Bar valve in it). Just grab and squeeze the top radiator hose and listen if it wheezes from the radiator cap.(this is best done when the engine is cold, for obvious reasons... )

also, hasthe system been bled properly?
The TU3JP4 engine is a bit of a .... to bleed properly.
Becase the bleed screw on the thermostat housing is lower than the top of the 'gallery' in the engine block/head, so you need to jack up the front lefthand corner as high as you can.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Head Light Bulbs
Last Post: dargoion
Today 05:52 PM
» Replies: 33
» Views: 977
radio code
Last Post: Tomcat3
Today 02:32 PM
» Replies: 3
» Views: 80
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Trevor
Today 02:13 PM
» Replies: 2
» Views: 38
Removing the rear roof storage bin (mk3 modutop)
Last Post: iscom
Today 01:31 PM
» Replies: 15
» Views: 6739
display fading (MFD B, not bulb related)
Last Post: saskak
Today 01:02 PM
» Replies: 41
» Views: 6100
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Today 12:13 PM
» Replies: 4
» Views: 243
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 12:07 PM
» Replies: 1
» Views: 59
Rear light bulb holders - keeps dropping bulb.
Last Post: Top drive
Today 12:01 PM
» Replies: 7
» Views: 296
What website to pass time over a winters evening...
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 1
» Views: 253
Good Evening to you all.
Last Post: VanFanDan1984
Today 11:57 AM
» Replies: 8
» Views: 233

[-]
Recent Visitors
Locations of visitors to this page