Thread Rating:
  • 8 Vote(s) - 3.13 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rev counter not working and temp guage hardly moves!
#1
Hi all, I have a Y reg Berlingo van, 1.9D. The rev counter does not move at all, sits at zero like a lame duck, and the temp guage reads very low, sometimes never at all. Wondering if this could be linked? The heaters are hot after 5 mins driving, and the engine is not overheating, so have ruled out the thermostat. Any ideas? I am wondering if it's a BSI thing, but know little about that little box of tricksConfusedcr
atch:!
Reply
#2
Hi. To me it sounds like you might have 2 faults.
If your gauge moves but only a bit, the problem still could be your thermostat in the cooling system. This could be stuck open not allowing the temp to rise fully. These can fail open and shut.
The rev counter could be a sensor but we need to know what engine you have to identify it.
If you can identify it your self or, PM me your Vin No. and I'll see what I can dig out.
Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#3
(19-10-2012, 06:59 PM)Rustscrat Wrote:  The rev counter could be a sensor but we need to know what engine you have to identify it.
If you can identify it your self or, PM me your Vin No. and I'll see what I can dig out.
Confusedalut:
Hi Rustcrat i have the same problem 2001 1.9 if i pm you my vin can you please help ?
Reply
#4
(23-11-2012, 08:41 PM)extinct Wrote:  
(19-10-2012, 06:59 PM)Rustscrat Wrote:  The rev counter could be a sensor but we need to know what engine you have to identify it.
If you can identify it your self or, PM me your Vin No. and I'll see what I can dig out.
Confusedalut:
Hi Rustcrat i have the same problem 2001 1.9 if i pm you my vin can you please help ?

Yep no worries. I can nowt but try. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#5
Ok got the drawings.
Can you tell me what exactly is not working + does the engine run fine or have you noticed a decrease in performance? Confusedcratch:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#6
Video 
I HAVE THIS VERY SAME PROBLEM COULD SOME ONE PLEASE HELP [/size]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
BULBS!!
Last Post: Jed Clampit
Yesterday 11:05 PM
» Replies: 17
» Views: 548
Finally a B9 Haynes Manual
Last Post: Satellitemark
Yesterday 10:43 PM
» Replies: 39
» Views: 2470
clunking noise
Last Post: Silverberlingo
Yesterday 10:35 PM
» Replies: 4
» Views: 60
TRAILER WANTED
Last Post: Silverberlingo
Yesterday 10:29 PM
» Replies: 4
» Views: 74
longitudinal roof rails
Last Post: Chrisville
Yesterday 10:27 PM
» Replies: 0
» Views: 17
Head Light Bulbs
Last Post: Hughzie
Yesterday 09:23 PM
» Replies: 36
» Views: 1130
Newbie
Last Post: Jed Clampit
Yesterday 08:37 PM
» Replies: 6
» Views: 86
first time ctroen owner
Last Post: Jed Clampit
Yesterday 08:25 PM
» Replies: 1
» Views: 34
M59 Cooling system change PDF
Last Post: coatess
Yesterday 06:46 PM
» Replies: 1
» Views: 209
What to look for when buying?
Last Post: polar
Yesterday 06:16 PM
» Replies: 6
» Views: 74

[-]
Recent Visitors
Locations of visitors to this page