Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Silly Newbie Electrical Fuse-type Question
#1
I have just bought a 2005 1.9D Berlingo Multispace Desire for my wife to use to ferry kids and, on occasion, lots of boxes for her business. It is very tidy, has a 12 mth ticket and is a lovely runner. It was (I think) very reasonably priced and we were/are pleased - the kids love the cubby holes and having their own personal gloveboxes! It however came with no handbook or manual.

All good so far....

Got it back yesterday and noticed en route that the radio wasn't working and looked as if it had just been slotted in....so I removed it with a wire coat-hanger and could see that it wasn't connected. Probably removed for an aftermarket one and stuck back in before selling it on.

So (foolishly, I'm guessing) I reconnected the wires and slotted it in....I should have disconnected the battery I think*. Any way, it still didn't work and here's a thing nor does the; (i) the instrument cluster (ii) the instrument cluster lights (iii) the hazard lights (iv) the central locking switch and probably some other things. Everything major is fine, the lights, windows, heater, fan etc so it is drivable in the very short term, though best to be over cautious at speed cameras!

Taking into account the odd array of now non-working things I am guessing that it is a fuse that I have popped by being an idiot? If so which one(s) as I can't find a fuse diagram on here that looks anything like the fuse board that I can find to the right of the steering wheel. The one in our van only has two rows of fuses and not very many at that....

Any help or advice would be appreciated.....I need it!



* I offer no defence other than that I don't generally do DIY/car maintenance/anything remotely practical excluding the very simplest of tasks because....I am particularly rubbish at it!
Reply
#2
Could this be a job for the BSI reset thing? (I found it in the answer to a similar query on here!)

"Put the driver's window down, lift the bonnet and ensure all equipment is switched off.
Ensure all doors are closed and remove key from the ignition.
Wait for 3 minutes, disconnect the vehicle battery and wait 15 seconds.
Reconnect the vehicle battery, wait a further 10 seconds (do not open doors.).
Switch on the side lights through the driver's window.
Switch on the ignition and check system's functionality.
Hold lock button on key down for 10 seconds.
Remove key open & close door test central locking system.
Start the engine and complete the system's check.
Failure to follow this procedure could result in incorrect operation of many BSI related items"

The remote key doesn't work so not sure I can do all of that.....aaaarrrgh!
[-] The following 1 user says Thank You to Darren Price for this post:
  • whitebus
Reply
#3
I would remove the wires that you connected to the radio then do the BSI reset, worse case is you should get it back to how it was.
--------------------------------------------------------------

2012 Iron Grey XTR 110 with lots of bits and bobs.
[-] The following 1 user says Thank You to Trevor for this post:
  • whitebus
Reply
#4
Don't worry about the remote key part just skip that bit it should do the reset, others have commented on this before.
When you say just wired it back was it a factory fit radio or aftermarket one.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#5
(12-02-2015, 07:30 PM)Tomcat3 Wrote:  Don't worry about the remote key part just skip that bit it should do the reset, others have commented on this before.
When you say just wired it back was it a factory fit radio or aftermarket one.

It was/is the factory fit one, I guess the previous owner stuck it back in as they removed an aftermarket DAB one or whatever. When I wired it back up the LED display worked with the clock and language on it but the radio was dead. Not too bothered about the radio, my missus wants an iPhone compatible DAB one anyway (Halfords have a £44 Pioneer one that'd fit the bill) I just want the instruments and other things to work! The radio is already disconnected and the loose wires wrapped in insulating tape, I will try the BSI reset before I take it to a garage and spend £££s - hopefully it will work and prevent me having to part with my cash!

Cheers all.

PS I suppose we will lose the steering wheel controls and the LED console if I have another radio unit installed? Is there a way round this?
Reply
#6
Hi Darren it sounds like the electrical block has been cut off that went into the back of the factory radio which would of made things easier, as you could of used a patch lead to your new unit. You can also get a patch lead to make the remote function work but you may have issues getting the clock to function. Have a search on radio replacement as there is many hours of reading on here.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
[-] The following 1 user says Thank You to Tomcat3 for this post:
  • whitebus
Reply
#7
Darren
Sounds like the fuse. I blew it fitting an aftermarket one.

From memory it's a 20 amp - orange one, somewhere in the middle of the pull out fuse board to the right of the steering wheel.
Reply
#8
(12-02-2015, 05:54 PM)Darren Price Wrote:    It however came with no handbook or manual.

Have you looked under the drivers seat ? 
Citroen decided that was a good place to have the handbook hidden for some reason. 
[-] The following 1 user says Thank You to TonyM for this post:
  • whitebus
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
glow plugs
Last Post: z1000pete
Today 10:21 AM
» Replies: 0
» Views: 5
You should have listened about facebook.
Last Post: poonamjs143
Today 10:11 AM
» Replies: 0
» Views: 12
Next gen berlingo multispace
Last Post: churmy
Today 09:42 AM
» Replies: 4
» Views: 63
Is anyone buying a new car AFTER April 2017?
Last Post: doofer
Today 09:10 AM
» Replies: 12
» Views: 220
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Hora
Today 07:04 AM
» Replies: 5
» Views: 152
Fuel rail pipe replacement
Last Post: polar
Today 06:54 AM
» Replies: 4
» Views: 99
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 45
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1558
Another seat belt question
Last Post: berreke
Yesterday 09:02 PM
» Replies: 1
» Views: 50
hi all
Last Post: Jed Clampit
Yesterday 08:39 PM
» Replies: 2
» Views: 52

[-]
Recent Visitors
Locations of visitors to this page