Thread Rating:
  • 5 Vote(s) - 2.6 Average
  • 1
  • 2
  • 3
  • 4
  • 5
So what is it ?
#1
Hi Folks, I have just joined as I am after some advice, firstly my Berlingo is a 52 plate 1.9D
So how do I know if it's a MK1 or MK11 ?

Secondly and more importantly...

Most of the time, the engine is nice and quiet, but sometimes on tick over (and sometimes when driving) the nice quite 1.9D tick over sound, is replaced by a dirty great huge noise that makes the engine sound like a 2.5d ford transit on a bad day.

My mate who I just got it off has had it for 4 years and said he has been told it's most prob the fuel pump and a lack of fuel causes the engine to rattle it's t*ts off.

I have sat and watched the rev counter when this happens and the revs drop about 100rpm, but as soon as I rev it up a bit, the noise returns to normal again.

This happens most of the time, but sometimes it will tick over quite nice and quiet.

Any idea's on both queries please ??

Eliminator
Reply
#2
Hello and welcome . Mk 1 has smaller head lamps and wing mirrors Confusedalut: As for differing engine noises can't help but someone who can may be along interfrastically or even sooner :wave:
[-] The following 1 user says Thank You to nil by mouth for this post:
  • Eliminator
Reply
#3
So I have now found out that I have a 2002 MK1 1.9D Berlingo

So anyone know anything about what kind of engine it is or what kind of fuel pump are in them ? (assuming that is what is making it sound like a transit van that's done 250,000 miles) ?
Reply
#4
maybe dw8 engine m8
Reply
#5
Still looking for peoples advice on this noise, would a slight fuel pump problem cause the engine to make a loud noise, then clear when you rev it ?
Reply
#6
Hi, if you PM me your vin No. I'll be able to tell you your engine,rpo No.,pump make etc. Confusedtudy:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#7
(18-02-2012, 10:48 PM)Eliminator Wrote:  Hi Folks, I have just joined as I am after some advice, firstly my Berlingo is a 52 plate 1.9D
So how do I know if it's a MK1 or MK11 ?

Secondly and more importantly...

Most of the time, the engine is nice and quiet, but sometimes on tick over (and sometimes when driving) the nice quite 1.9D tick over sound, is replaced by a dirty great huge noise that makes the engine sound like a 2.5d ford transit on a bad day.

My mate who I just got it off has had it for 4 years and said he has been told it's most prob the fuel pump and a lack of fuel causes the engine to rattle it's t*ts off.

I have sat and watched the rev counter when this happens and the revs drop about 100rpm, but as soon as I rev it up a bit, the noise returns to normal again.

This happens most of the time, but sometimes it will tick over quite nice and quiet.

Any idea's on both queries please ??

Eliminator

Hi
it sounds to me if you are getting a slight air leak into the fuel feed. The injector pump has a pump built into it that sucks/draws the fuel from the tank, via the fuel filter. It sounds to me that the injector/fuel pump is drawing too much air to fuel when idling, when revved it sucks enough fuel to get it running properly. If there is a slight leak in the pipeline somewhere between the priming bulb and the injector pump its possible to have an air leak into the fuel pipe which will not show as fuel leaking out.
> You could try pumping the fuel priming bulb which may show a fuel leak then.
Another cause can be a hairline fracture in the fuel feed pickup in the tank itself which draws air and not enought fuel when idling. This can be found if it acts normally on a full tank and starts erratic idling on a lowish tank.
:wave:
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Odd Issues with Rear Door Sensor
Last Post: GerardKeating
Today 12:27 AM
» Replies: 0
» Views: 3
Gearbox Fluid
Last Post: AlanS
Today 12:18 AM
» Replies: 14
» Views: 331
REAR AXCEL
Last Post: ajcommercial
Yesterday 11:57 PM
» Replies: 0
» Views: 6
Fuel Guage wrong
Last Post: ajcommercial
Yesterday 11:46 PM
» Replies: 2
» Views: 94
Longitudinal Roof rails on 2010 model
Last Post: Chrisville
Yesterday 08:42 PM
» Replies: 0
» Views: 26
radio code
Last Post: Tomcat3
Yesterday 07:14 PM
» Replies: 1
» Views: 40
Donation
Last Post: terryd999
Yesterday 06:15 PM
» Replies: 2
» Views: 39
Beeping with no error lights!!!
Last Post: sjparky
Yesterday 05:34 PM
» Replies: 11
» Views: 3760
Good Evening to you all.
Last Post: ron
Yesterday 04:33 PM
» Replies: 7
» Views: 208
New Berlingo Auto Box - Anyone have one?
Last Post: rubberrat
Yesterday 01:30 PM
» Replies: 3
» Views: 209

[-]
Recent Visitors
Locations of visitors to this page