Thread Rating:
  • 10 Vote(s) - 3.7 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Speedo Stopped Working
#1
First post on here (Hi Chaps) - I have a 2006 Berlingo 1.9 DW8 van, the other week while driving on the motorway there was an audible noise (Almost like a rotating clicking noise) from behind the clocks and the speedo suddenly stopped working. All the other gauges and illumination on the facia still work fine. Any pointers as to the likely fault, I know the speed sensors are prone to going on these but as far as I am aware these are fitted into the gearbox bellhousing so I'm curious to know what the noise was just before the speedo stopped before I just start replacing parts .... from experience that gets expensive !!
Reply
#2
Hi, does your digital mileometer still count / illuminate? :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#3
[u]
(13-02-2013, 09:40 AM)Rustscrat Wrote:  Hi, does your digital mileometer still count / illuminate? :thumbsup:


Hi, Sorry forgot to mention that bit - The mileometer still illuminates but and shows the mileage on intial startup and then flicks straight over to the tripmeter which stays at 0.0 miles and won't count.
Reply
#4
My speedo has been hit and miss for two and a half years, even went through an mot not working, I've learnt to judge my speed by the rev counter and gear I'm in, I'm pretty good at it now
Somedays you're the pigeon, Somedays you're the statue.
Reply
#5
Try a Bsi reset and then check Fuse 1 in your engine fuse box. (for speed sensor)Confusedalut:

http://www.bba-reman.com/content.aspx?co...ot_process
2006 2.0hdi 600 with bench seat.  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 33
Next gen berlingo multispace
Last Post: churmy
Yesterday 10:30 PM
» Replies: 0
» Views: 24
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1496
Is anyone buying a new car AFTER April 2017?
Last Post: Jed Clampit
Yesterday 09:25 PM
» Replies: 10
» Views: 178
Another seat belt question
Last Post: berreke
Yesterday 09:02 PM
» Replies: 1
» Views: 36
hi all
Last Post: Jed Clampit
Yesterday 08:39 PM
» Replies: 2
» Views: 42
Tyre Change...old on front new on back
Last Post: RocketVANman
Yesterday 08:26 PM
» Replies: 12
» Views: 196
New Berlingo Auto Box - Anyone have one?
Last Post: doofer
Yesterday 08:10 PM
» Replies: 8
» Views: 333
Newbie
Last Post: j.ted
Yesterday 08:03 PM
» Replies: 6
» Views: 104
Fuel rail pipe replacement
Last Post: Peter Palmer
Yesterday 04:50 PM
» Replies: 3
» Views: 89

[-]
Recent Visitors
Locations of visitors to this page