Thread Rating:
  • 8 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Spring Rubbing issue
#1
Hello all,

I have owned a 04 plate berlingo 2.0 HDi for 3 years. One year into ownership and the front drivers side suspension spring snapped. I got a new one from eurocarparts and fitted it. Ever since fitting it when steering there was a rubbing noise. I found the very top of the spring was rubbing against the cars inner wheel arch.

Things i have considered:

I have does something incorrect when putting it all back together.

I have put the spring in the wrong way around. Looks like it could go in either way though.

The spring is wrong, even though it fits the cups nice.


Any suggestions are welcome. I currently have the stut off and the spring out. Looking through the top mount hole you can see where it has been rubbing.

Note sure what to do now?

Cheers
Bob

euro car part no. 627545140 was fitted.
Found this on another post
"i had a broken spring replaced and the garage had not seated the top bearing correctly which caused a twang on bumps and turns."

Looked at how the top bearing seats and i can not see that as being the problem.
Reply
#2
Can you get a picture of the rubbing ?
Reply
#3
yeah that is a good idea. To dark now to take a good photo but I will upload first thing tomorrow. I'm not the best at describing things so a picture be better.

Looks like the spring has been rubbing agaist the chassis. Right at the top. I have looked at the other side and it is close, but not touching. Not sure how this has occurred. It was the first time i swapped a spring so could well be something i have done.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
600lx or 800lx
Last Post: terryd999
Today 05:16 PM
» Replies: 0
» Views: 4
Fuel rail pipe replacement
Last Post: Peter Palmer
Today 04:50 PM
» Replies: 3
» Views: 71
hi all
Last Post: Andre
Today 04:07 PM
» Replies: 1
» Views: 19
New Berlingo Auto Box - Anyone have one?
Last Post: CourierJim
Today 03:47 PM
» Replies: 7
» Views: 312
Tyre Change...old on front new on back
Last Post: CourierJim
Today 03:37 PM
» Replies: 11
» Views: 157
Is anyone buying a new car AFTER April 2017?
Last Post: CourierJim
Today 03:30 PM
» Replies: 7
» Views: 139
Slow starter (diesel)
Last Post: zedhead
Today 03:22 PM
» Replies: 13
» Views: 302
Are Mud Flaps the Answer ?
Last Post: berreke
Today 02:13 PM
» Replies: 13
» Views: 365
Insurance cost
Last Post: jonny705
Today 02:12 PM
» Replies: 3
» Views: 87
Starting issues
Last Post: brajomobil
Today 11:56 AM
» Replies: 1
» Views: 55

[-]
Recent Visitors
Locations of visitors to this page