Thread Rating:
  • 5 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Starting issue
#1
Hi, got a 1.9 Citreon Diesel van ( 600 ). When I turn on the ignition on the orange glow plug light on the dashboard instantly goes off instead of staying on for the usual ten seconds or so. This is making it almost impossible to start the van, the van will run as normal with carb start but not on it's own from the key as the glow plugs are obviously not getting warm.

any ideas what part is broken and stopping the glow plugs heating up?
Reply
#2
see this post

http://www.berlingoforum.co.uk/showthread.php?tid=1875

:thumbsup:

or this one
http://www.berlingoforum.co.uk/showthread.php?tid=3891
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
glow plugs
Last Post: z1000pete
Today 10:21 AM
» Replies: 0
» Views: 18
Next gen berlingo multispace
Last Post: churmy
Today 09:42 AM
» Replies: 4
» Views: 81
Is anyone buying a new car AFTER April 2017?
Last Post: doofer
Today 09:10 AM
» Replies: 12
» Views: 222
Sop the seatbelt buckle sitting soo low?/aux ste...
Last Post: Hora
Today 07:04 AM
» Replies: 5
» Views: 153
Fuel rail pipe replacement
Last Post: polar
Today 06:54 AM
» Replies: 4
» Views: 100
600lx or 800lx
Last Post: dumdum
Yesterday 11:12 PM
» Replies: 1
» Views: 46
Advise please on known problem tyre scrubbing
Last Post: shncoe1
Yesterday 10:12 PM
» Replies: 19
» Views: 1567
Another seat belt question
Last Post: berreke
Yesterday 09:02 PM
» Replies: 1
» Views: 51
hi all
Last Post: Jed Clampit
Yesterday 08:39 PM
» Replies: 2
» Views: 54
Tyre Change...old on front new on back
Last Post: RocketVANman
Yesterday 08:26 PM
» Replies: 12
» Views: 213

[-]
Recent Visitors
Locations of visitors to this page