Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Steering & Suspension] Heavy Steering
#1
Hi All

the PAS pump went on one of the vans which then decided to leak fluid all over the Alternator.

I've changed the Alti and the PAS pump (Both new units) and all was we all good, Steering was brilliant and everything worked as it should.

After a trip down the motorway I came off to find the steering has gone heavy again.

I have checked the following
- Power steering fluid
- AUX Belt
- Sprayed the U/J
-Turned the Steering wheel side to side to see if there was any air stuck in the system

All of the above came back normal as it should but the steering is still heavy unless the van is jacked up and then it goes light again (even with only one side jacked)

Does anyone have any other ideas on what the issue could be as the last few days have been driving be crazy trying to work out what hasd cause the issue.

Many Thanks

Chris
Reply
#2
The strut tops can suffer wear, their wafer-thin bearings seize, rubbers fail causing incorrect camber, also look right up the strut in case the coil has broken near the top.

If it's all good you may have a faulty pinion valve in the rack.
Reply
#3
(11-05-2014, 12:18 PM)addo Wrote:  The strut tops can suffer wear, their wafer-thin bearings seize, rubbers fail causing incorrect camber, also look right up the strut in case the coil has broken near the top.

If it's all good you may have a faulty pinion valve in the rack.

Thanks for the reply addo

Could the bearings really have gone that fast?

I was only driving for maybe 20mins on the motorway before i came off?

Checked the springs and they are all fine there

Whats the best way to check the pinion valve on the rack?

Chris
Reply
#4
Easiest way to check the pinion valve is by rack substitution with a known good one. I'm presuming you flushed the fluid after changing the pump?

That said, normal mode of control valve failure is hard steering in one direction only.
Reply
#5
(11-05-2014, 12:52 PM)addo Wrote:  Easiest way to check the pinion valve is by rack substitution with a known good one. I'm presuming you flushed the fluid after changing the pump?

That said, normal mode of control valve failure is hard steering in one direction only.


Yes the fluid was flushed after changing the pump.

I've got hard steering both ways so i'm unsure if that would stray way from it being the valve?

Chris
Reply
#6
Pump the tyres upto 60psi that's what someone else done lol.
I DO MISS MY BERLINGO Heart
Reply
#7
Just a thought,Colunm UJ seizing?Confusedcratch:
Strawberry flavoured windows  Dodgy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
What to look for when buying?
Last Post: my mucker
Today 04:59 PM
» Replies: 7
» Views: 105
Next gen berlingo multispace
Last Post: doofer
Today 04:19 PM
» Replies: 17
» Views: 315
Taking along time to heat up/warm the cabin
Last Post: jj9
Today 10:57 AM
» Replies: 10
» Views: 199
Are Mud Flaps the Answer ?
Last Post: doofer
Today 10:01 AM
» Replies: 15
» Views: 478
Head Light Bulbs
Last Post: doofer
Today 09:51 AM
» Replies: 37
» Views: 1209
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 08:54 AM
» Replies: 3
» Views: 134
New tablet fitted
Last Post: Andre
Today 08:31 AM
» Replies: 1
» Views: 65
January Picture of the Month Contest
Last Post: Andre
Today 08:22 AM
» Replies: 1
» Views: 131
1.6hdiTurbo Over Boost OBD code P0234
Last Post: berlingo16hdif
Yesterday 11:00 PM
» Replies: 11
» Views: 14496
Supermarket Diesel
Last Post: Silverberlingo
Yesterday 08:26 PM
» Replies: 6
» Views: 160

[-]
Recent Visitors
Locations of visitors to this page