Thread Rating:
  • 9 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Temp gauge reads high all the time
#1
Berlingo 2.0 hdi van on an 02 plate, temp gauge stays on high, stop light on. Engine fan continually running, Checked not overheating and full coolant, replaced temp sensor in engine compartment, still not fixed.... Any ideas please
Reply
#2
Hi, the temp sensor (should be green with two wires) goes straight back to the engine ecu on the 48pin brown plug.
Do a shutdown procedure and disconnect the battery.
have a look at these connections and make sure they are clean / no corrosion.
Don't forget to do a correct start up procedure.

What happens if you leave the sensor disconnected? Confusedcratch:
Do you still get the same fault?

http://www.bba-reman.com/content.aspx?co...ot_process

Confusedalut:
2006 2.0hdi 600 with bench seat.  Cool
Reply
#3
(21-06-2012, 06:57 PM)Rustscrat Wrote:  Hi, the temp sensor (should be green with two wires) goes straight back to the engine ecu on the 48pin brown plug.
Do a shutdown procedure and disconnect the battery.
have a look at these connections and make sure they are clean / no corrosion.
Don't forget to do a correct start up procedure.

What happens if you leave the sensor disconnected? Confusedcratch:
Do you still get the same fault?

http://www.bba-reman.com/content.aspx?co...ot_process

Confusedalut:

Hi, thanks for the reply, if I leave the sensor disconnected, same fault. Sensor has been replaced with a new one. I took off the 48 pin plug and gave it a spray with wd40, it looks clean. Unsure of shutdown procedure, then followed your link Smile I will try that tomorrow (Cornwall, it's heaving down with rain!) when I get to work and a shelter. Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
600lx or 800lx
Last Post: terryd999
Today 05:16 PM
» Replies: 0
» Views: 4
Fuel rail pipe replacement
Last Post: Peter Palmer
Today 04:50 PM
» Replies: 3
» Views: 71
hi all
Last Post: Andre
Today 04:07 PM
» Replies: 1
» Views: 19
New Berlingo Auto Box - Anyone have one?
Last Post: CourierJim
Today 03:47 PM
» Replies: 7
» Views: 312
Tyre Change...old on front new on back
Last Post: CourierJim
Today 03:37 PM
» Replies: 11
» Views: 157
Is anyone buying a new car AFTER April 2017?
Last Post: CourierJim
Today 03:30 PM
» Replies: 7
» Views: 139
Slow starter (diesel)
Last Post: zedhead
Today 03:22 PM
» Replies: 13
» Views: 302
Are Mud Flaps the Answer ?
Last Post: berreke
Today 02:13 PM
» Replies: 13
» Views: 365
Insurance cost
Last Post: jonny705
Today 02:12 PM
» Replies: 3
» Views: 87
Starting issues
Last Post: brajomobil
Today 11:56 AM
» Replies: 1
» Views: 55

[-]
Recent Visitors
Locations of visitors to this page