Thread Rating:
  • 6 Vote(s) - 3.17 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The inicators don't stay on.
#1
2003 Berlingo 1.9D

The right is worse than left but basically I have to hold the indicator stalk firmly in position to keep indicating.

Sometimes even then it's hit and miss.

Is it a common problem with an easy fix? (I hope so, haha)

Any advice appreciated.
Many thanks.
Reply
#2
Same thing happened to my MK2 twice.

Have a look at the 'How to get to Berlingo COM 2000 Unit' Thread
woodshaper
Sole Member and President for LIFE!
Reply
#3
Thanks, so do you think I'm going to need new stalks?
Reply
#4
(03-12-2011, 11:56 PM)MattFreeman Wrote:  Thanks, so do you think I'm going to need new stalks?

If remember right the entire unit with the stalks on was replaced by the dealer under warranty, but the same thing happened again not long afterwards when using the left indicator position.
Suspect it was a broken piece in the switch body rather than an electrical one.
It was on an 07 MK2 XTR.

Sure that someone else on the Forum will be able to offer more info.

woodshaper
Sole Member and President for LIFE!
Reply
#5
It's definitely a mechanical problem in the stalk (a piece broken) not an electrical connection issue.
Does anyone know if it's fixable with some ingenuity and some epoxy glue perhaps?

I guess the first thing is to take it all apart.
Does anyone have anything more to offer?
Reply
#6
Solved! I took the covers off (without removing the whole assembly and steering weel) I then gave all the internals a good flooding of contact cleaner (solvent in a spray can) and operated the mechanism 50 or 60 times. Now my indicators stay on and operate perfectly every time. It must have just been some grime/ corrosion on the contact. Happy days!
Reply
#7
Glad to hear it was a simple fix, did you follow the removal tutorial that is on the forum out of interest?
Want Help with the Forum? Read Help Documents Here
 [Image: mybbsig.php]

Reply
#8
I didn't need to Andre, I just removed the plastic covers which was quite self explanatory.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Taking along time to heat up/warm the cabin
Last Post: Hora
Today 12:37 PM
» Replies: 0
» Views: 9
Slow starter (diesel)
Last Post: ricc
Today 11:53 AM
» Replies: 15
» Views: 337
Mesh Bulkhead
Last Post: Jelevents
Today 11:37 AM
» Replies: 0
» Views: 15
2005 Berlingo
Last Post: len glover
Today 10:10 AM
» Replies: 6
» Views: 95
Supermarket Diesel
Last Post: polar
Today 09:28 AM
» Replies: 4
» Views: 49
clunking noise
Last Post: ffrenchie
Today 09:26 AM
» Replies: 5
» Views: 85
BULBS!!
Last Post: Jed Clampit
Yesterday 11:05 PM
» Replies: 17
» Views: 602
Finally a B9 Haynes Manual
Last Post: Satellitemark
Yesterday 10:43 PM
» Replies: 39
» Views: 2497
TRAILER WANTED
Last Post: Silverberlingo
Yesterday 10:29 PM
» Replies: 4
» Views: 87
longitudinal roof rails
Last Post: Chrisville
Yesterday 10:27 PM
» Replies: 0
» Views: 30

[-]
Recent Visitors
Locations of visitors to this page