Thread Rating:
  • 7 Vote(s) - 3.43 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] Overheating problem
#1
Help please
Hi I have a Citroen Berlingo multispace forte 1.9 diesel (51 plate) on a trip yesterday 16 miles (motorway) half way there and the stop sign came on, checked the water before I left and it was full. Stopped and had to put 2 litres of water in it?, the fan was racing for 10 mins after stopping, carried on the rest of the 8 miles and the temp gage went up and down , about an inch of water less when I got there. Got more water for the journey back and it was ok except for the radiator light flashing on and off . Checked all the usual signs for cylinder head problems no steam from exhaust , oil level ok and water still ok. The only noticeable thing is the fan is loud when I stop and takes a while to go off. Any help appreciated
Reply
#2
Is there water in the footwells? Just thinking of a leaking heater matrix if there are no other visible leaks.
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#3
(15-07-2013, 11:17 AM)Landmark Wrote:  Is there water in the footwells? Just thinking of a leaking heater matrix if there are no other visible leaks.
Griff

Thanks for answering , no nothing in the footwells.
Reply
#4
Try flushing the cooling system & changing the thermostat.
:thumbsup:
Strawberry flavoured windows  Dodgy
Reply
#5
It's normal that the fan runs after the engine is switched off, if the engine got very hot. And yeah, it's noisy.
Does your car have an AC?
If not, there's probably a thermoswitch on the radiator itself, which controls the fan directly. (The fact that the fan is running would then definitely mean that the thermostat works. There's no way for that area of the radiator to get that hot without liquid circulating)

The big problem is 'where did the 2 liters go?'
(I assume that it didn't boil when you stopped to add water?)

Are there no wet spots under the car?

The fact that the temperature 'jumped up and down' on the return an be because of air trapped in the system. (There's a few bleed screws for that)

There's two hoses going between the radiator and engine. The top hose leads water from the engine, and is connected to the thermostat housing. If this hose is very hot, it's an even bet that the Thermostat is working as expected.

You will have to replace some of the water with proper anti-freeze(Glycol) soon, as the mix you're running now is mostly water and will cause lots of damage to the system in the long run.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Highest milage on a mk3
Last Post: Hora
Today 02:54 AM
» Replies: 51
» Views: 10973
Newbie
Last Post: polar
Today 02:31 AM
» Replies: 3
» Views: 44
Just to say hi
Last Post: polar
Today 02:29 AM
» Replies: 4
» Views: 80
2005 Berlingo
Last Post: polar
Today 02:27 AM
» Replies: 5
» Views: 69
Are Mud Flaps the Answer ?
Last Post: andylobb
Yesterday 09:51 PM
» Replies: 14
» Views: 413
Next gen berlingo multispace
Last Post: Jed Clampit
Yesterday 08:49 PM
» Replies: 8
» Views: 138
TRAILER WANTED
Last Post: Silverberlingo
Yesterday 08:21 PM
» Replies: 0
» Views: 28
glow plugs
Last Post: brodfather11
Yesterday 08:03 PM
» Replies: 1
» Views: 54
New Berlingo Auto Box - Anyone have one?
Last Post: Capelbond
Yesterday 04:10 PM
» Replies: 9
» Views: 370
Finally a B9 Haynes Manual
Last Post: Satellitemark
Yesterday 02:32 PM
» Replies: 37
» Views: 2423

[-]
Recent Visitors
Locations of visitors to this page