Thread Rating:
  • 2 Vote(s) - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] engine management light
#1
I bought 1.4 petrol/lpg berlingo 57 plate last week everyting was ok on the begining but few days ago the engine management light came on. When i start the engine at the morning from cold the light is coming on and stay constantly on for while and the van is in limp mode then around 80C on the temperature gauge the light start flashing for 2-3 min beeps and stays (stop flashing) and the van pulls better. I tried on petrol aswell does exactly the same thing. The van is a bit juicy on lpg aswell does around 20mpg in london (heavy traffic) is this normal ? I just wonder if someone can help me with this before i go to the garage
PS. sorry if i mispelled something my english is not the best Smile
Reply
#2
Hi, I would get it plugged in to a fault finder , you could be causing damage to your car !
Reply
#3
(27-10-2013, 02:25 PM)royboy302 Wrote:  Hi, I would get it plugged in to a fault finder , you could be causing damage to your car !

I will do it this week to see whats happend anyway i stopped driving the van Sad
Reply
#4
Today i plugged into a fault finder and show misfire of couple cylinders which make sense to me now the van was lumpy and ''shaking'' on idles i think new spark plugs will sort the problem Smile
Reply
#5
No, that's the coil pack. If you keep driving it can damage the ECU.
[-] The following 3 users say Thank You to addo for this post:
  • ron, royboy302, sabin
Reply
#6
so is not the spark plugs Sad ? You reckon is the coil pack i will change the plugs tomorrow and will buy coil pack to stay on save side i have long jorney to bulgaria on end of the month Smile Could you recomend one ? The range price is from 34-100 pounds i dont know is any difference ?
Reply
#7
I would recommend a known manufacturer, Bosch, Bougicord, NGK, Beru for example.
[-] The following 2 users say Thank You to addo for this post:
  • ron, royboy302
Reply
#8
Thanks Addo Smile , I changed the sparks and the coil pack today is better now specially on idle Smile (bought one for £50)
I think i have to erase the fault , because the light remains on the dashboard and the problem will be sorted Smile
Reply
#9
I'm pleased there has been improvement!
Reply
#10
Have a good trip.:thumbsup::thumbsup:
Strawberry flavoured windows  Dodgy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
[-]
Welcome
You have to register before you can post on our site.

Username:
  

Password:
  




[-]
Search
(Advanced Search)

[-]
Latest Threads
Taking along time to heat up/warm the cabin
Last Post: jj9
Today 10:57 AM
» Replies: 10
» Views: 193
Next gen berlingo multispace
Last Post: Solent
Today 10:20 AM
» Replies: 16
» Views: 305
Are Mud Flaps the Answer ?
Last Post: doofer
Today 10:01 AM
» Replies: 15
» Views: 475
Head Light Bulbs
Last Post: doofer
Today 09:51 AM
» Replies: 37
» Views: 1203
Help needed have immobiliser fault and fan probl...
Last Post: brajomobil
Today 08:54 AM
» Replies: 3
» Views: 134
New tablet fitted
Last Post: Andre
Today 08:31 AM
» Replies: 1
» Views: 64
January Picture of the Month Contest
Last Post: Andre
Today 08:22 AM
» Replies: 1
» Views: 130
1.6hdiTurbo Over Boost OBD code P0234
Last Post: berlingo16hdif
Yesterday 11:00 PM
» Replies: 11
» Views: 14488
Supermarket Diesel
Last Post: Silverberlingo
Yesterday 08:26 PM
» Replies: 6
» Views: 157
2005 Berlingo
Last Post: len glover
Yesterday 07:23 PM
» Replies: 7
» Views: 128

[-]
Recent Visitors
Locations of visitors to this page